Bone Collector

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?
Bone Collector_第1张图片

Input

The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

Sample Input

      
      
      
      
1 5 10 1 2 3 4 5 5 4 3 2 1

Sample Output

      
      
      
      
14
 
做完这题我彻底崩溃,原来我把val,vol写反了,好想哭啊。。。。
#include<iostream>
#include<cmath>
using namespace std;
int dp[1005];
int w[1005],c[1005];
int main()
{
    int i,j,n,v,t;
    scanf("%d",&t);
    while(t--)
    {
      scanf("%d%d",&n,&v);
      memset(dp,0,sizeof(dp));
      for(i=1;i<=n;i++)
        scanf("%d",&w[i]);
      for(i=1;i<=n;i++)
        scanf("%d",&c[i]);
      for(i=1;i<=n;i++)
      {
        for(j=v;j>=c[i];j--)
        {
         
            dp[j]=max(dp[j],dp[j-c[i]]+w[i]);
        }
      }
      printf("%d\n",dp[v]);
    }
    return 0;
}


 #include<iostream>
#include<cmath>
using namespace std;
int dp[1005][1005];
int val[1005],vol[1005];
int main()
{
    int i,j,n,v,t;
    scanf("%d",&t);
    while(t--)
    {
      scanf("%d%d",&n,&v);
      memset(dp,0,sizeof(dp));
      for(i=1;i<=n;i++)
        scanf("%d",&val[i]);
      for(i=1;i<=n;i++)
        scanf("%d",&vol[i]);
      for(i=1;i<=n;i++)
      {
        for(j=0;j<=v;j++)
        {
            if(j>=vol[i]&&dp[i-1][j]<dp[i-1][j-vol[i]]+val[i])
               dp[i][j]=dp[i-1][j-vol[i]]+val[i];
            else dp[i][j]=dp[i-1][j];
        }
      }
      printf("%d\n",dp[n][v]);
    }
    return 0;
}
    
   

你可能感兴趣的:(Bone Collector)