HDOJ 畅通工程再续 1875

畅通工程再续

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17709    Accepted Submission(s): 5526


Problem Description
相信大家都听说一个“百岛湖”的地方吧,百岛湖的居民生活在不同的小岛中,当他们想去其他的小岛时都要通过划小船来实现。现在政府决定大力发展百岛湖,发展首先要解决的问题当然是交通问题,政府决定实现百岛湖的全畅通!经过考察小组RPRush对百岛湖的情况充分了解后,决定在符合条件的小岛间建上桥,所谓符合条件,就是2个小岛之间的距离不能小于10米,也不能大于1000米。当然,为了节省资金,只要求实现任意2个小岛之间有路通即可。其中桥的价格为 100元/米。
 

Input
输入包括多组数据。输入首先包括一个整数T(T <= 200),代表有T组数据。
每组数据首先是一个整数C(C <= 100),代表小岛的个数,接下来是C组坐标,代表每个小岛的坐标,这些坐标都是 0 <= x, y <= 1000的整数。
 

Output
每组输入数据输出一行,代表建桥的最小花费,结果保留一位小数。如果无法实现工程以达到全部畅通,输出”oh!”.
 

Sample Input
   
   
   
   
2 2 10 10 20 20 3 1 1 2 2 1000 1000
 

Sample Output
   
   
   
   
1414.2 oh!
 

Author
8600
 

Source
2008浙大研究生复试热身赛(2)——全真模拟
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1102  1301  1856  1325  3371

这道题跪好几遍。。。。。最后才发现跪到了memset上,纳闷在这为何不能用memset将数组赋值为INF。。。。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0x3f3f3f3f
using namespace std;
int N;
int par[110];
struct edge{
    double x,y;
}num[110];
double d[110];
bool used[110];
double cost[101][101];
int find(int x){
    int son,temp;
    son=x;
    while(x!=par[x])
    x=par[x];
    while(son!=x){
        temp=par[son];
        par[son]=x;
        son=temp;
    }
    return x;
}
void unite(int x,int y){
    x=find(x);
    y=find(y);
    if(x!=y)
    par[x]=y;
}
double prim()
{
    for(int i=1;i<=N;i++){
        used[i]=false;
        d[i]=INF;
    }
    d[1]=0;
    double res=0;
    while(1){
        int v=-1;
        for(int i=1;i<=N;i++)
        if(!used[i]&&(v==-1||d[v]>d[i]))v=i;
        if(v==-1)break;
        if(d[v]==INF)return d[v];
        used[v]=true;
        res+=d[v];
        for(int i=1;i<=N;i++)
        d[i]=min(d[i],cost[v][i]);
    }
    return res;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&N);
        double a,b;
        for(int i=1;i<=N;i++){
            scanf("%lf%lf",&a,&b);
            num[i].x=a;
            num[i].y=b;
        }
        for(int i=1;i<=N;i++)
        par[i]=i;
       // memset(cost,INF,sizeof(cost));
        for(int i=1;i<=N;i++){
			for(int j=1;j<=N;j++){
				if(i==j)cost[i][j]=0;
				else cost[i][j]=INF;
			}
        }
        double l,money;
        for(int i=1;i<=N;i++){
            for(int j=i+1;j<=N;j++){
                l=sqrt((num[j].x-num[i].x)*(num[j].x-num[i].x)+((num[j].y-num[i].y))*(num[j].y-num[i].y));
                if(l>=10.0&&l<=1000.0){
                    unite(i,j);
                    money=l*100.0;
                    if(cost[i][j]>money){
						cost[i][j]=money;
                        cost[j][i]=money;
                    }
                }
            }
        }
        int sum=0;
        for(int i=1;i<=N;i++)
        if(par[i]==i)sum++;
        double res=prim();
        if(sum>1||res==INF)printf("oh!\n");
        else
        printf("%.1lf\n",res);
    }
    return 0;
}


你可能感兴趣的:(HDOJ 畅通工程再续 1875)