zoj 3211 Dream City(DP)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3211

转载请注明出处:http://blog.csdn.net/u012860063


Dream City

Time Limit: 1 Second       Memory Limit: 32768 KB



JAVAMAN is visiting Dream City and he sees a yard of gold coin trees. There are n trees in the yard. Let's call them tree 1, tree 2 ...and tree n. At the first day, each treei has ai coins on it (i=1, 2, 3...n). Surprisingly, each tree i can grow bi new coins each day if it is not cut down. From the first day, JAVAMAN can choose to cut down one tree each day to get all the coins on it. Since he can stay in the Dream City for at most m days, he can cut down at most m trees in all and if he decides not to cut one day, he cannot cut any trees later. (In other words, he can only cut down trees for consecutive m or less days from the first day!)

Given nmai and bi (i=1, 2, 3...n), calculate the maximum number of gold coins JAVAMAN can get.

Input

There are multiple test cases. The first line of input contains an integer T (T <= 200) indicates the number of test cases. Then T test cases follow.

Each test case contains 3 lines: The first line of each test case contains 2 positive integers n and m (0 < m <= n <= 250) separated by a space. The second line of each test case contains n positive integers separated by a space, indicating ai. (0 < ai <= 100, i=1, 2, 3...n) The third line of each test case also contains n positive integers separated by a space, indicating bi. (0 < bi <= 100, i=1, 2, 3...n)

Output

For each test case, output the result in a single line.

Sample Input

2
2 1
10 10
1 1
2 2
8 10
2 3

Sample Output

10
21

Hints:
Test case 1: JAVAMAN just cut tree 1 to get 10 gold coins at the first day.
Test case 2: JAVAMAN cut tree 1 at the first day and tree 2 at the second day to get 8 + 10 + 3 = 21 gold coins in all.

Author:  CAO, Peng

Source: The 6th Zhejiang Provincial Collegiate Programming Contest


题意:

有n棵树,最多待m天!每天可以砍一颗树且可以得到所砍树的金币!未砍的树每天会生长bi的金币!原有的金币为ai;求:m天最多能得到的金币数!

PS:

必须连续砍树!如果有一天没有砍树 之后就不能再砍了!


dp[i][j]:表示在前i棵树中砍j棵能得到的最大金币数量!

dp[i][j] = max(dp[i-1][j], dp[i-1][j-1]+shu[i].a+shu[i].b * (j-1));


代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#define M 1005
using namespace std;
struct node
{
	int a, b;
}shu[M];
int max(int a,int b)
{
	int x =a > b ? a:b;
	return x;
}
bool cmp(node x , node y)
{
	return x .b < y.b;
}
int dp[M][M];
int main()
{
	
	memset(shu,0,sizeof(shu));
	memset(dp,0,sizeof(dp));
	int n , m , i , j ,k , t;
	while(~scanf("%d",&t))
	{
		while(t--)
		{
			scanf("%d%d",&n,&m);
			for(i = 1 ; i <= n ; i++ )
			{
				scanf("%d",&shu[i].a);
			}
			for(i = 1 ; i <= n ; i++ )
			{
				scanf("%d",&shu[i].b);
			}
			sort(shu+1,shu+n+1,cmp);
			for(i = 1 ; i <= n ; i++ )
			{
				for(j = 1 ; j <= m ; j++ )
				{
					dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]+shu[i].a+shu[i].b * (j-1));
				}
			}
			printf("%d\n",dp[n][m]);
		}
	}
	return 0;
}


你可能感兴趣的:(dp,ZOJ)