hdu 5512 Pagodas(沈阳区域赛重现)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5512

Pagodas

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 446    Accepted Submission(s): 331


Problem Description
n pagodas were standing erect in Hong Jue Si between the Niushou Mountain and the Yuntai Mountain, labelled from 1 to n . However, only two of them (labelled a and b , where 1abn ) withstood the test of time.

Two monks, Yuwgna and Iaka, decide to make glories great again. They take turns to build pagodas and Yuwgna takes first. For each turn, one can rebuild a new pagodas labelled i (i{a,b} and 1in) if there exist two pagodas standing erect, labelled j and k respectively, such that i=j+k or i=jk . Each pagoda can not be rebuilt twice.

This is a game for them. The monk who can not rebuild a new pagoda will lose the game.
 

Input
The first line contains an integer t (1t500) which is the number of test cases.
For each test case, the first line provides the positive integer n (2n20000) and two different integers a and b .
 

Output
For each test case, output the winner (``Yuwgna" or ``Iaka"). Both of them will make the best possible decision each time.
 

Sample Input
   
   
   
   
16 2 1 2 3 1 3 67 1 2 100 1 2 8 6 8 9 6 8 10 6 8 11 6 8 12 6 8 13 6 8 14 6 8 15 6 8 16 6 8 1314 6 8 1994 1 13 1994 7 12
 

Sample Output
   
   
   
   
Case #1: Iaka Case #2: Yuwgna Case #3: Yuwgna Case #4: Iaka Case #5: Iaka Case #6: Iaka Case #7: Yuwgna Case #8: Yuwgna Case #9: Iaka Case #10: Iaka Case #11: Yuwgna Case #12: Yuwgna Case #13: Iaka Case #14: Yuwgna Case #15: Iaka Case #16: Iaka
 

Source
2015ACM/ICPC亚洲区沈阳站-重现赛(感谢东北大学)

题目大意:先输入一个t,表示有t组测试数据。接下去t行,每行有n a b 分别表示有n个塔,a,b就是题目中叙述的j和k,(j和k表示的是已经修好的塔的编号)。Yuwgna先开始进行修塔,最后没得修的就输了。需要注意的是每次可以进行修建的塔需要满足i=j+k或者i=j-k。

解题思路: 1、先判断一下a和b中是否存在1,如果存在的话,任何一个塔都可以进行修建。
         2、如果a和b中不存在1,就判断一下a和b是否互质,如果互质的话,肯定会出现1的情况,这样又可以每一个塔都可以修建。
         3、不互质的话,可以修建塔的位置的个数就只有n/gcd(a, b);然后最后判断总共可以修建的塔的个数是奇数还是偶数就ok了。
详见代码。
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int gcd(int a,int b)
{
    if (a%b==0)
        return b;
    return gcd(b,a%b);
}

int main()
{
    int t;
    int c=1;
    scanf("%d",&t);
    while (t--)
    {
        int flag=0;
        int n,a,b;
        scanf("%d%d%d",&n,&a,&b);
        if (a==1||b==1)
        {
            if (n%2==1)
                flag=1;
        }
        else
        {
            if (gcd(a,b)==1)
            {
                if (n%2==1)
                    flag=1;
            }
            else
            {
                int k=n/gcd(a,b);
                if (k%2==1)
                    flag=1;
            }
        }
        printf ("Case #%d: ",c++);
        if (flag==1)
            printf ("Yuwgna\n");
        else
            printf ("Iaka\n");
    }
    return 0;
}





你可能感兴趣的:(hdu 5512 Pagodas(沈阳区域赛重现))