UVA - 455 Periodic Strings

Periodic Strings
Time Limit: 3000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

Submit Status

Description

 Periodic Strings 

A character string is said to have period k if it can be formed by concatenating one or more repetitions of another string of length k. For example, the string "abcabcabcabc" has period 3, since it is formed by 4 repetitions of the string "abc". It also has periods 6 (two repetitions of "abcabc") and 12 (one repetition of "abcabcabcabc").

Write a program to read a character string and determine its smallest period.

Input

The first line oif the input file will contain a single integer N indicating how many test case that your program will test followed by a blank line. Each test case will contain a single character string of up to 80 non-blank characters. Two consecutive input will separated by a blank line.

Output

An integer denoting the smallest period of the input string for each input. Two consecutive output are separated by a blank line.

Sample Input

1

HoHoHo

Sample Output

2

求周期串:

int len = strlen(s);                            

for (int i = 1; i <= len; i++)

                   if(len%i==0)

                   {

                            intok = 1;

                            for(int j = i; j < len;j++)

                            if(s[j] != s[j%i])

                            {

                                     ok= 0; break;

                            }

                            if(ok)

                            {

                                     cout<< len / i << endl;

                                     break;

                            }

                   }

#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	int casen;
	cin >> casen;
	while (casen--)
	{
		char s[10000]; cin >> s;
		int len = strlen(s);

		for (int i = 1; i <= len; i++)
		if (len%i == 0)
		{
			bool ok = 1;
			for (int j = i; j < len; j++)
			if (s[j] != s[j%i])
			{
				ok = 0;
				break;
			}

			if (ok)
			{
				cout << i << endl;
				break;
			}
		}
		if (casen)
			cout << endl;
	}
}


你可能感兴趣的:(UVA - 455 Periodic Strings)