A+B for Input-Output Practice (V)
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 64946 Accepted Submission(s): 43409
Problem Description
Your task is to calculate the sum of some integers.
Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line.
Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input.
Sample Input
Sample Output
Author
lcy
原题链接: http://acm.hdu.edu.cn/showproblem.php?pid=1093
C语言AC代码:
#include <stdio.h>
int main()
{
int n,m,x,sum;
scanf("%d",&n);
while(n--)
{
scanf("%d",&m);
sum=0;
while(m--)
{
scanf("%d",&x);
sum+=x;
}
printf("%d\n",sum);
}
return 0;
}
Java AC代码:
public class Main {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
int n = sc.nextInt();
while(n-->0){
int m = sc.nextInt();
int sum = 0;
while(m-->0){
int x = sc.nextInt();
sum += x;
}
System.out.println(sum);
}
}
}