八连块(类似水池数目(nyoj27),水池问题只有四个方向, 八连快有八个方向)

八连块

Time Limit:1 Ms| Memory Limit:128 MB
Difficulty:1

Description
输入一个n*n(n最大为30)的黑白图像(1表示黑色,0表示白色),任务是统计其中八连块的个数。如果两个黑格子有公共边或者有公共顶点,就说它们属于同一个八连块。
如下图所示,八连块的个数为3。
100100
001010
000000
110000
111000
010100
Input
第一行输入一个n 表示图的大小
接下来n行 用来表示图的组成
Output
输出八连块的个数
Sample Input
6
100100
001010
000000
110000
111000
010100
Sample Output
3

代码:

#include <stdio.h>

int a[30][30];
int num;
int n;

int movex[] = {1, 0, -1, 0, 1, -1, -1, 1};
int movey[] = {0, -1, 0, 1, -1, -1, 1, 1};

void dfs(int x, int y) {
	for(int i=0; i<8; i++) {
		int tx = x + movex[i];
		int ty = y + movey[i];
		if(tx>=0&&tx<n && ty>=0&&ty<n && a[tx][ty]) {
			a[tx][ty] = 0;
			dfs(tx, ty);
		}
	}
}

int main(void) {
	scanf("%d", &n);
	for(int i=0; i<n; i++)
		for(int j=0; j<n; j++)
			scanf("%1d", &a[i][j]);

	num = 0;
	for(int i=0; i<n; i++)
		for(int j=0; j<n; j++) {
			if(a[i][j] == 1) {
				num++;
				dfs(i, j);
			}
		}
	printf("%d\n", num);

	return 0;
}




你可能感兴趣的:(八连块(类似水池数目(nyoj27),水池问题只有四个方向, 八连快有八个方向))