北大ACM poj3051 Satellite Photographs

Satellite Photographs

Description

Farmer John purchased satellite photos of W x H pixels of his farm (1 <= W <= 80, 1 <= H <= 1000) and wishes to determine the largest 'contiguous' (connected) pasture. Pastures are contiguous when any pair of pixels in a pasture can be connected by traversing adjacent vertical or horizontal pixels that are part of the pasture. (It is easy to create pastures with very strange shapes, even circles that surround other circles.)

Each photo has been digitally enhanced to show pasture area as an asterisk ('*') and non-pasture area as a period ('.'). Here is a 10 x 5 sample satellite photo:

..*.....**
.**..*****
.*...*....
..****.***
..****.***

This photo shows three contiguous pastures of 4, 16, and 6 pixels. Help FJ find the largest contiguous pasture in each of his satellite photos.

Input

* Line 1: Two space-separated integers: W and H

* Lines 2..H+1: Each line contains W "*" or "." characters representing one raster line of a satellite photograph.

Output

* Line 1: The size of the largest contiguous field in the satellite photo.

Sample Input

10 5
..*.....**
.**..*****
.*...*....
..****.***
..****.***

Sample Output

16
//3051
#include<stdio.h>
#include<string.h>
char map[1001][1001];
int n,m,sum,max;
void dfs(int i,int j)
{
	if((map[i][j]=='.')||i<0||j<0||i>=n||j>=m) return;
	else
	{
	   map[i][j]='.';
	   sum++; 
	   dfs(i-1,j);
	   dfs(i,j-1);
	   dfs(i,j+1);
	   dfs(i+1,j);

	}
}
int main()
{
	int i,j;
	while(scanf("%d%d",&m,&n)!=EOF)
	{
		if(m==0) break;
		max=0;
		for(i=0;i<n;i++)
			scanf("%s",map[i]);
		for(i=0;i<n;i++)
		{
			for(j=0;j<m;j++)
			{
				sum=0;
				if(map[i][j]=='*')
				{
					dfs(i,j);
		     	}
		     	if(max<sum)max=sum;
		    }
	   	}
	   	printf("%d\n",max);
	}
	return 0;
}

你可能感兴趣的:(北大ACM poj3051 Satellite Photographs)