HDU 1045 Fire Net

Fire Net

                                                       Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
                                                                         Total Submission(s): 6249    Accepted Submission(s): 3520



Problem Description
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.

HDU 1045 Fire Net_第1张图片

Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Input
The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.
 

Output
For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.
 

Sample Input
   
   
   
   
4 .X.. .... XX.. .... 2 XX .X 3 .X. X.X .X. 3 ... .XX .XX 4 .... .... .... .... 0
 

Sample Output
   
   
   
   
5 1 5 2 4
 

题意:

我们有一方形城市,街道都是直的。有n行n列,每格代表一条街道或一堵墙。每个碉堡有四个射击孔,分别正对东南西北方向。子弹威力无比,射程无限,并能摧毁它所击中的碉堡。另外,墙很坚固,能阻止子弹的摧毁。

在城市中布置尽可能多的碉堡,它们之间又不相互摧毁。求合理配置碉堡的最大数目。

'.' 代表空地,'X' 代表墙。

分析:

由于问题规模小(n <= 4)

采用深度优先搜索,从左往右,从上往下遍历.

代码如下:

#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
char cMap[4][4];
int iVis[4][4], n, iMax;
bool Canput(int row, int col)
{
    for(int i = row - 1; i >= 0; i --)
    {
        if(cMap[i][col] == 'o') return false;  //判断col列上的合法性
        if(cMap[i][col] == 'X') break;   //碰到墙,能放,继续判断
    }
    for(int i = col - 1; i >= 0; i --)
    {
        if(cMap[row][i] == 'o') return false;  //判断row行上的合法性
        if(cMap[row][i] == 'X') break;
    }
    return true;
}
void slove(int pos, int cur)  //对每个单元格pos能否放置碉堡进行判断
{
    if(pos == n * n)
    {
        if(cur > iMax)  //更新最优解
        {
            iMax = cur;
            return;
        }
    }
    else
    {
        int x = pos / n;  //将单元数转换为坐标
        int y = pos % n;
        if(cMap[x][y] == '.' && Canput(x, y))  //若本单元格可以放置
        {
            cMap[x][y] = 'o';   //放置一个
            slove(pos + 1, cur + 1);   //递归到下一个
            cMap[x][y] = '.';   //恢复该单元格,为下一个放置方式作准备
        }
        slove(pos + 1, cur);   //本单元格不放碉堡
    }
}

int main()
{
    while(~scanf("%d", &n), n)
    {
        iMax = 0;
        memset(iVis, 0, sizeof(iVis));
        for(int i = 0; i < n; i ++)
            scanf("%s", &cMap[i]);
        slove(0, 0);
        cout <<iMax <<endl;
    }
    return 0;
}


你可能感兴趣的:(HDU 1045 Fire Net)