1037. Magic Coupon

1037. Magic Coupon (25)

时间限制
100 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.

Sample Input:
4
1 2 4 -1
4
7 6 -2 -3
Sample Output:
43
//有个bug,用scanf函数作为输入的时候,你会发现,sort排序,对于正数和负数的排序结果是分开的,以后用到sort的时候,得不到最终的结果,最好改用到cin进行输入,
//1037. Magic Coupon
//你可以把cin,cout换成scanf,printf再跑一下试试。test sort()打印一下v1,v2中的值看看 
#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;

vector<long long> v1;
vector<long long> v2;

int main()
{
	int n, m;
	
	cin>>n;
	for(int i = 0; i < n; i ++)
	{
		long long tmp;
		cin>>tmp;
		v1.push_back(tmp);
	}
	
	cin>>m;
	if(n == 0 || m == 0)
	{
		cout<<"0"<<endl;
		return 0;
	}
	for(int i = 0; i < m; i ++)
	{
		long long tmp;
		cin>>tmp;
		v2.push_back(tmp);
	}
	
	sort(v1.begin(), v1.end());
	sort(v2.begin(), v2.end());
	
	//test sort()

	
	int start1 = 0, end1 = v1.size()-1;
	int start2 = 0, end2 = v2.size()-1;
	long long sum = 0;
	while(start1 <= end1 && start2 <= end2 && v1[start1] < 0 && v2[start2] < 0)
	{
		sum += v1[start1]*v2[start2];
		start1 ++;
		start2 ++;
	}
	while(end1 >= 0 && end2 >= 0 && v1[end1] > 0 && v2[end2] > 0)
	{
		sum += v1[end1]*v2[end2];
		end1 --;
		end2 --;
	}
	cout<<sum<<endl;
	
	return 0;
}


你可能感兴趣的:(1037. Magic Coupon)