BestCoder Round #76 (div.2)A

DZY Loves Balls

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 623    Accepted Submission(s): 369



思路:强行暴力即可;
Problem Description
DZY loves playing balls.

He has n balls in a big box. On each ball there is an integer written.

One day he decides to pick two balls from the box. First he randomly picks a ball from the box, and names it A . Next, without putting A back into the box, he randomly picks another ball from the box, and names it B .

If the number written on A is strictly greater than the number on B , he will feel happy.

Now you are given the numbers on each ball. Please calculate the probability that he feels happy.
 

Input
First line contains t denoting the number of testcases.

t testcases follow. In each testcase, first line contains n , second line contains n space-separated positive integers ai , denoting the numbers on the balls.

( 1t300,2n300,1ai300 )
 

Output
For each testcase, output a real number with 6 decimal places.
 

Sample Input
   
   
   
   
2 3 1 2 3 3 100 100 100
 

Sample Output
   
   
   
   
0.500000 0.000000
 

Source
BestCoder Round #76 (div.2)
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5654  5653  5649  5648  5647

#include <iostream>
#include<cstdio>
#include <algorithm>
#include <cmath>
#include <stack>
#include <cstring>
using namespace std;
int A[321];
int main()
{
    int t;
    int n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=0;i<n;i++)
            cin>>A[i];
        int cnt=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<n;j++)
            {
                if(A[j]>A[i])
                    cnt++;
            }
        }
        printf("%.6lf\n",(double)cnt/(n*(n-1)));
    }
    return 0;
}

 

你可能感兴趣的:(BestCoder Round #76 (div.2)A)