UVA 536 - Tree Recovery

 

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes.

This is an example of one of her creations:

 

                                    D
                                   / \
                                  /   \
                                 B     E
                                / \     \
                               /   \     \ 
                              A     C     G
                                         /
                                        /
                                       F

To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).

For the tree drawn above the preorder traversal isDBACEGFand the inorder traversal isABCDEFG.

She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it).

 


Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree.

However, doing the reconstruction by hand, soon turned out to be tedious.

So now she asks you to write a program that does the job for her!

 

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.)

Input is terminated by end of file.

 

Output Specification

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

 

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

 

Sample Output

ACBFGED
CDAB

 

 

 

#define RUN
#ifdef RUN


#include<stdio.h>
#include<string.h>
const int MAXN = 30;

//因为先序遍历的第一个字符就是根,所以只需在中序遍历中找到它的位置,
//就能递归遍历其左右子树
//根据长度为n的先序序列s1和中序序列s2,构造一个长度为n的后序序列
void build(int n, char* s1, char* s2, char* s) {
  if(n <= 0) return;
  //找到根结点在中序遍历中的位置
  int p = strchr(s2, s1[0]) - s2;
  //递归构造左子树的后序遍历
  build(p, s1+1, s2, s);
  //递归构造右子树的后序遍历
  build(n-p-1, s1+p+1, s2+p+1, s+p);
  //把根节点添加到最后
  s[n-1] = s1[0];
}

int main() {

#ifndef ONLINE_JUDGE
	freopen("536.in", "r", stdin);
	freopen("536.out", "w", stdout); 
#endif

  char s1[MAXN], s2[MAXN], ans[MAXN];
  while(scanf("%s%s", s1, s2) == 2) {
    int n = strlen(s1);
    build(n, s1, s2, ans);
    ans[n] = '\0';
    printf("%s\n", ans);
  }
  return 0;
}

#endif



 

你可能感兴趣的:(tree)