UVA 490 - Rotating Sentences

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them from top to bottom and right to left.

 

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper case English letters. (NOTE: Tabs are not legal characters.)

 

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

 

Sample Input

 

Rene Decartes once said,
"I think, therefore I am."

 

Sample Output

 

"R
Ie
 n
te
h 
iD
ne
kc
,a
 r
tt
he
es
r
eo
fn
oc
re
e
 s
Ia
 i
ad
m,
. 
" 

#define RUN
#ifdef RUN

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <vector>
#include <list>
#include <cctype> 
#include <algorithm>
#include <utility>
#include <math.h>

using namespace std;

#define MAXN 105

char buf[MAXN][MAXN];
char c;
int rows = 0;	// Total rows of input
int len = 0;	// Length of each row
int maxlen = 0;

void printout(){
	for(int i=0; i<rows; i++){
		for(int j=0; j<strlen(buf[i]); j++){
			printf("%c", buf[i][j]);
		}
		printf("\n");
	}
}

void rotate(){
	for(int i=0; i<maxlen; i++){
		for(int j=rows-1; j>=0; j--){
			printf("%c", buf[j][i]);
		}
		printf("\n");
	}
}



int main(){

#ifndef ONLINE_JUDGE
	freopen("490.in", "r", stdin);
	freopen("490.out", "w", stdout); 
#endif

	memset(buf, ' ', sizeof(buf));

	while(scanf("%c", &c)!=EOF){
		if(c == '\n'){
			if(len > maxlen){
				maxlen = len;
			}
			len = 0;
			rows++;
			continue;
		}

		buf[rows][len++] = c;
	}

	//printout();
	rotate();

}


#endif

你可能感兴趣的:(uva)