杭电 3172 Virtual Friends【并查集 + map容器】



                                           Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6041    Accepted Submission(s): 1705

Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends' friends, their friends' friends' friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends.

Your task is to observe the interactions on such a website and keep track of the size of each person's network.

Assume that every friendship is mutual. If Fred is Barney's friend, then Barney is also Fred's friend.
 

Input
Input file contains multiple test cases.
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

Sample Input
   
   
   
   
1 3 Fred Barney Barney Betty Betty Wilma
 

Sample Output
   
   
   
   
2 3 4
 
#include <map>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
using namespace std;
#define Fin(IN) freopen(IN,"r",stdin)
const int maxn = 200000+20;//人数最多为 2N
int p[maxn],root_cnt[maxn];
map<string,int>Map;
int Find(int x) {return x == p[x]?x:p[x] = Find(p[x]);}
int Union(int a,int b){
    int pa = Find(a);
    int pb = Find(b);
    if(pa != pb) {p[pb] = pa;root_cnt[pa] += root_cnt[pb];}
    return root_cnt[pa];
}
int main(){
    //Fin("F:\\ACM刷题\\ACM专题训练\\in.txt");
    int T;
    while(cin>>T){
        while(T--){
            //cout<<"--------"<<endl;
            int n,cnt = 0;
            Map.clear();
            scanf("%d",&n);
            for(int i = 1;i < n*2;i++) {p[i] = i;root_cnt[i] = 1;}
            for(int i = 1;i <= n;i++){
                char a[25],b[25];
                scanf("%s%s",a,b);//scanf()效率比cin高
                //string a,b;
                //cin>>a>>b;
                if(!Map[a]) Map[a] = ++cnt;
                if(!Map[b]) Map[b] = ++cnt;
                int ans = Union(Map[a],Map[b]);
                //这样一个个扫描是肯定会TLE的
                //int ans = 0;
                //ans = root_cnt[a]
                /*const int CTP = p[Map[a]];
                for(int i = 1;i <= cnt;i++){
                    if(CTP == p[i]) ans++;
                }
                */
                cout<<ans<<endl;
            }
        }
    }
    return 0;
}




你可能感兴趣的:(map,ACM,并查集)