ZOJ 2829 Beautiful Number

Beautiful Number Time Limit: 2 Seconds       Memory Limit: 65536 KB

Mike is very lucky, as he has two beautiful numbers, 3 and 5. But he is so greedy that he wants infinite beautiful numbers. So he declares that any positive number which is dividable by 3 or 5 is beautiful number. Given you an integer N (1 <= N <= 100000), could you please tell mike the Nth beautiful number?

Input

The input consists of one or more test cases. For each test case, there is a single line containing an integer N.

Output

For each test case in the input, output the result on a line by itself.

Sample Input

1
2
3
4

Sample Output

3
5
6
9


打表
#include <cstdio>
#include <cstring>
using namespace std;

int main()
{
    int n;
    int num[220000];
    int ans[100001];
    int flag;
        memset(num, 0, sizeof(num));
        memset(ans, 0, sizeof(ans));
        for (int i = 1; i * 3 <= 220000; i++){
            num[i * 3] = 1;
        }
        for (int i = 1; i * 5 <= 220000; i++){
            num[i * 5] = 1;
        }
        flag = 1;
        for (int i = 1; i < 220000; i++){
            if (num[i] == 1){
                ans[flag++] = i;
            }
        }
        while (scanf("%d", &n) != EOF){
            printf("%d\n", ans[n]);
        }
    return 0;
}


你可能感兴趣的:(ZOJ 2829 Beautiful Number)