POJ 3624 背包水题

POJ 3624

01背包水题。

Description

  • Bessie has gone to the mall’s jewelry store and spies a charm bracelet. Of course, she’d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability’ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

  • Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

  • Line 1: Two space-separated integers: N and M
  • Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

  • Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraint

Sample Input

  • 4 6
  • 1 4
  • 2 6
  • 3 12
  • 2 7

Sample Output

  • 23

代码

#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;

int dp[12900];

int main()
{
   int n,m;
   scanf("%d%d",&n,&m);
   sizeof(dp,0,sizeof(dp));
   int w[3500];
   int d[3500];
   for (int i = 0;i<n;i++)
     scanf("%d%d",&w[i],&d[i]);
   for (int i = 0;i<n;i++)
    for (int j = m;j>=w[i];j--)
       dp[j] = max(dp[j],dp[j-w[i]]+d[i]);
    printf("%d\n",dp[m]);
}

你可能感兴趣的:(ACM-背包)