hdu1058 Humble Numbers

Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers. 

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
   
   
   
   
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
   
   
   
   
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
University of Ulm Local Contest 1996
 
解法:
        这个题目之前Google面试时考过,用四个指针p2,p3,p5,p7存储当前可考虑的数,然后下一个数肯定是取p2*2, p3*3, p5*5, p7*7中最小的一个,更新完成之后,再移动p2,p3,p5,p7。

代码:
#include <iostream>
#include <cstdio>
using namespace std;

typedef long long lld;

static const int iLen = 6000;
static const char* lpstrPreFix[] = { "th", "st", "nd", "rd", "th", "th", "th", "th", "th", "th", "th", "th", "th", "th", "th", "th", "th", "th", "th", "th" };

lld dp[iLen];

void InitDp();

int main(){
	InitDp();
	int n;
	scanf("%d", &n);
	while (n){
		if (n % 10 == 1 && n % 100 != 11)
			printf("The %I64dst humble number is %I64d.\n", n, dp[n]);
		else if (n % 10 == 2 && n % 100 != 12)
			printf("The %I64dnd humble number is %I64d.\n", n, dp[n]);
		else if (n % 10 == 3 && n % 100 != 13)
			printf("The %I64drd humble number is %I64d.\n", n, dp[n]);
		else
			printf("The %I64dth humble number is %I64d.\n", n, dp[n]);
		scanf("%d", &n);
	}
}

inline int ChooseMin(int p2, int p3, int p5, int p7);

void InitDp(){
	dp[1] = 1;
	int p2, p3, p5, p7;
	p2 = p3 = p5 = p7 = 1;
	lld x, y, z, w, cc;
	for (int i = 2; i < iLen; ++i){
		x = (dp[p2] << 1);
		y = (dp[p3] << 1) + (dp[p3]);
		z = (dp[p5] << 2) + (dp[p5]);
		w = (dp[p7] << 2) + (dp[p7] << 1) + (dp[p7]);
		if (x <= y && x <= z && x <= w){//x
			cc = x;
		}
		else if (y <= x && y <= z && y <= w){//y
			cc = y;
		}
		else if (z <= x && z <= y && z <= w){//z
			cc = z;
		}
		else{//w
			cc = w;
		}
		dp[i] = cc;
		while (dp[p2] * 2 <= dp[i])
			++p2;
		while (dp[p3] * 3 <= dp[i])
			++p3;
		while (dp[p5] * 5 <= dp[i])
			++p5;
 		while (dp[p7] * 7 <= dp[i])
			++p7;
	}
}

AC结果:
Run ID Submit Time Judge Status Pro.ID Exe.Time Exe.Memory Code Len. Language Author
15646204 2015-11-25 20:47:09 Accepted 1058 62MS 1608K 1514 B G++ BossJue



你可能感兴趣的:(Google,ACM,HDU,OJ)