POJ 1469二分图最大匹配

COURSES
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 15672   Accepted: 6189

Description

Consider a group of N students and P courses. Each student visits zero, one or more than one courses. Your task is to determine whether it is possible to form a committee of exactly P students that satisfies simultaneously the conditions:

  • every student in the committee represents a different course (a student can represent a course if he/she visits that course)
  • each course has a representative in the committee

Input

Your program should read sets of data from the std input. The first line of the input contains the number of the data sets. Each data set is presented in the following format:

P N
Count1 Student 1 1 Student 1 2 ... Student 1 Count1
Count2 Student 2 1 Student 2 2 ... Student 2 Count2
...
CountP Student P 1 Student P 2 ... Student P CountP

The first line in each data set contains two positive integers separated by one blank: P (1 <= P <= 100) - the number of courses and N (1 <= N <= 300) - the number of students. The next P lines describe in sequence of the courses �from course 1 to course P, each line describing a course. The description of course i is a line that starts with an integer Count i (0 <= Count i <= N) representing the number of students visiting course i. Next, after a blank, you抣l find the Count i students, visiting the course, each two consecutive separated by one blank. Students are numbered with the positive integers from 1 to N.
There are no blank lines between consecutive sets of data. Input data are correct.

Output

The result of the program is on the standard output. For each input data set the program prints on a single line "YES" if it is possible to form a committee and "NO" otherwise. There should not be any leading blanks at the start of the line.

Sample Input

2
3 3
3 1 2 3
2 1 2
1 1
3 3
2 1 3
2 1 3
1 1

Sample Output

YES
NO

1Y
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <algorithm>

using namespace std;

const int N=1005;
const int maxn=1005;

int map[N][N],Linker[maxn];
int used[maxn];

int res,Num,P;

int DFS(int u)
{
     int v;
     for(v=1;v<=Num;v++)
     {
         if(map[u][v]&&!used[v])
         {
             used[v]=1;
             if(Linker[v]==-1||DFS(Linker[v]))
             {
                 Linker[v]=u;
                return 1;
             }
         }
     }
     return 0;
}

int Hungary()
{
     int res=0;
     int u;
     memset(Linker,-1,sizeof(Linker));
     for(u=1;u<=P;u++)
     {
         memset(used,0,sizeof(used));
        if(DFS(u))
             res++;
     }
     return res;
}

int main()
{
     int test,temp,n,v,i,u;
     scanf("%d",&test);
     while(test--)
     {
         scanf("%d%d",&P,&Num);
         memset(map,0,sizeof(map));
         memset(Linker,-1,sizeof(Linker));
         for(u=1;u<=P;u++)
         {
             scanf("%d",&n);
             for(i=1;i<=n;i++)
             {
                 scanf("%d",&v);
                 map[u][v]=1;
             }
         }
         res=Hungary();
         if(res==P)
             puts("YES");
         else
             puts("NO");
     }
     return 0;
}

 

你可能感兴趣的:(POJ 1469二分图最大匹配)