sicily 1190. Reduced ID Numbers

1190. Reduced ID Numbers

Constraints

Time Limit: 2 secs, Memory Limit: 32 MB

Description

T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input

On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output

For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

题目分析

求一个数,使给定的数模它结果不同
暴力枚举,时间给了两秒


#include <iostream>
#include <map>

int id[301];
int count;

bool check(int k) {
  std::map<int, int> m;
  for (int i = 0; i < count; ++i) {
    int temp = id[i] % k;
    if (m[temp] == 0)
      m[temp] = 1;
    else
      return false;
  }
  return true;
}


int main()
{
  int test;
  std::cin >> test;
  while (test--) {
    std::cin >> count;
    for (int i = 0; i < count; ++i)
      std::cin >> id[i];
    int ans;
    for (ans = 1; !check(ans); ++ans);
    std::cout << ans << std::endl;
  }  
}

你可能感兴趣的:(sicily 1190. Reduced ID Numbers)