zzulioj 1807: 小明在努力 (机智递归)

1807: 小明在努力

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 97   Solved: 36

Submit Status Web Board

Description

小明是个很勤劳的孩子,为了挣钱养家糊口,来到了某建筑工地搬砖挣钱。
奇怪的包工头让小明把卡车卸下来的那堆砖分成一块一块的(要求任何2块转都要分开)。作为资深搬运工,小明总是每次将一堆砖分为两堆,这时候,所消耗的体力是分完之后的两堆砖数目的差值的绝对值。
现在,已知卡车运来的砖的数目,请告诉小明最少要花费多少体力才能完成包工头所要求的任务呢?

Input

有多组测试数据(不超过120组),每组数据有一个正整数N(N<=10^9),表示卡车运来的砖块的数目。

Output

对于每组数据,请输出小明完成任务所需的最少体力数。

Sample Input

4
5

Sample Output

0
2
#include<stdio.h>
#include<string.h>
int find(int n)
{
	int sum=0;
	if(n==1)
		return 0;
	if(n%2==0)
		sum+=find(n/2)*2;
	else
	{
		sum+=find(n/2);
		sum+=find(n/2+1);
		sum++;
	}
	return sum;
}
int main()
{
	int n,m;
	while(scanf("%d",&n)!=EOF)
	{
		printf("%d\n",find(n));
	}
	return 0;
}

//队友用优先队列写超时。。
#include<iostream>
#include<queue>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct Node
{
	int v,n;
};
queue<Node>dl;
int main()
{
	int N;
	while(~scanf("%d",&N))
	{
		while(!dl.empty())
			dl.pop();
		int l,r,ans=0;
		Node a,b;
		a.v=N;a.n=1;
		if(N>1)dl.push(a);
		while(!dl.empty())
		{
			a=dl.front();
			dl.pop();
			if(a.v%2==0)
			{
				while(a.v%2==0)
				{
					a.n*=2;
					a.v/=2;
				}
				if(a.v<=1)
					continue;
				dl.push(a);
				continue;
			}
			l=(a.v+1)>>1;
			r=a.v-l;
			ans+=a.n;
			if(l>1)a.v=l;
				dl.push(a);
			if(r>1)a.v=r;
				dl.push(a);
		}
		printf("%d\n",ans);
	}
	return 0;
}

你可能感兴趣的:(zzulioj 1807: 小明在努力 (机智递归))