uva 10098 Generating Fast, Sorted Permutation

Generating Fast, Sorted Permutation

Input: Standard Input

Output: Standard Output

 

Generating permutation has always been an important problem in computer science. In this problem you will have to generate the permutation of a given string in ascending order.  Remember that your algorithm must be efficient.


Input

The first line of the input contains an integer n, which indicates how many strings to follow. The next n lines contain n strings. Strings will only contain alpha numerals and never contain any space. The maximum length of the string is 10.

 
Output

For each input string print all the permutations possible in ascending order. Not that the strings should be treated, as case sensitive strings and no permutation should be repeated. A blank line should follow each output set.

 

Sample Input

3
ab
abc
bca

 

Sample Output

ab
ba

abc
acb
bac
bca
cab
cba

abc
acb
bac
bca
cab
cba

题目大意:生成所给字符串的所有排序,按字典序输出。

解题思路:尝试了运用next_permutation(),题目完全没由什么意思了。

#include<iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;

#define N 20

int main()
{
	int n;
	char str[N];

	scanf("%d", &n);

	while(n--)
	{
		// Init.
		memset(str, 0, sizeof(str));

		// Read.
		scanf("%s", str);
		int m = strlen(str);
		sort(str, str + m);
		do{
			printf("%s\n", str);
		}while(next_permutation(str, str + m));
		cout << endl;
	}
	return 0;}

你可能感兴趣的:(uva 10098 Generating Fast, Sorted Permutation)