【poj2752】Seek the Name, Seek the Fame KMP

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

POJ Monthly–2006.01.22,Zeyuan Zhu

从nxt[n]一直沿失配边走,走过的下标即为答案。

自己画画就懂…不知道怎么解释…

注意EOF是-1

#include<stack>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

const int SZ = 10000010;

int nxt[SZ];

void getnxt(char s[])
{
    nxt[0] = 0;
    nxt[1] = 0;
    int n = strlen(s);
    for(int i = 1;i < n;i ++)
    {
        int j = nxt[i];
        while(j && s[i] != s[j]) j = nxt[j];
        nxt[i + 1] = s[i] == s[j] ? j + 1 : 0;
    }
}

stack<int> g;

char s[SZ];

int main()
{
    while(~scanf("%s",s))
    {
        getnxt(s);
        int j = strlen(s);

        while(j) g.push(j),j = nxt[j];

        while(g.size())
            printf("%d ",g.top()),g.pop();
        puts("");
    }
    return 0;
}


你可能感兴趣的:(【poj2752】Seek the Name, Seek the Fame KMP)