[poj 1703] Find them, Catch them 并查集应用

Find them, Catch them
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39600 Accepted: 12166

Description
The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

  1. D [a] [b]
    where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

  2. A [a] [b]
    where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.

Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output
For each message “A [a] [b]” in each case, your program should give the judgment based on the information got before. The answers might be one of “In the same gang.”, “In different gangs.” and “Not sure yet.”

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

Source
POJ Monthly–2004.07.18
题目链接:http://poj.org/problem?id=1703

题意
给你一定的关系。把嫌疑犯分成两个团伙。询问关系;

思路:类比食物链,开2*n的数组
1–n代表本我,n+1–2n代表黑暗我;

unio(aa+n,bb);
unio(bb+n,aa);

D x y 把(x与黑暗y(y+n))unio合并

查询if(find(aa)==find(bb)) 在同组

if(find(aa+n)==find(bb)||find(aa)==find(bb+n))```是敌人

代码

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
int n,m;
int fa[100002*2];
void init(int nn)
{
    for(int i=1;i<=nn;i++)
    fa[i]=i;
}

char s[3];
int aa,bb;
int find(int x)
{
    if(fa[x]==x) return x;
    return fa[x]=find(fa[x]);
}
void unio(int x,int y)
{
    fa[find(x)]=find(y);

}

int main()
{   
    int T;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        init(2*n);
        for(int i=1;i<=m;i++)
        {
            scanf("%s%d%d",s,&aa,&bb);
            if(s[0]=='A')
            {
                //cout<<find(aa)<<" "<<find(aa+n)<<" "<<find(bb)<<" "<<find(bb+n)<<endl;
                if(find(aa)==find(bb))
                printf("In the same gang.\n");
                else if(find(aa+n)==find(bb)||find(aa)==find(bb+n))
                printf("In different gangs.\n");
                else printf("Not sure yet.\n");
            }
            if(s[0]=='D')
            {
                unio(aa+n,bb);
                unio(bb+n,aa);
            }
        }   
    }

}

你可能感兴趣的:(poj,应用)