我的第二个 USACO Training--Greedy Gift Givers

题目:

A group of NP (2 ≤ NP ≤ 10) uniquely named friends has decided to exchange gifts of money. Each of these friends might or might not give some money to any or all of the other friends. Likewise, each friend might or might not receive money from any or all of the other friends. Your goal in this problem is to deduce how much more money each person gives than they receive.

The rules for gift-giving are potentially different than you might expect. Each person sets aside a certain amount of money to give and divides this money evenly among all those to whom he or she is giving a gift. No fractional money is available, so dividing 3 among 2 friends would be 1 each for the friends with 1 left over -- that 1 left over stays in the giver's "account".

In any group of friends, some people are more giving than others (or at least may have more acquaintances) and some people have more money than others.

Given a group of friends, no one of whom has a name longer than 14 characters, the money each person in the group spends on gifts, and a (sub)list of friends to whom each person gives gifts, determine how much more (or less) each person in the group gives than they receive.

IMPORTANT NOTE

The grader machine is a Linux machine that uses standard Unix conventions: end of line is a single character often known as '\n'. This differs from Windows, which ends lines with two charcters, '\n' and '\r'. Do not let your program get trapped by this!

PROGRAM NAME: gift1

INPUT FORMAT

Line 1: The single integer, NP
Lines 2..NP+1: Each line contains the name of a group member
Lines NP+2..end: NP groups of lines organized like this:
The first line in the group tells the person's name who will be giving gifts.
The second line in the group contains two numbers: The initial amount of money (in the range 0..2000) to be divided up into gifts by the giver and then the number of people to whom the giver will give gifts, NGi (0 ≤ NGi ≤ NP-1).
If NGi is nonzero, each of the next NGi lines lists the the name of a recipient of a gift.

SAMPLE INPUT (file gift1.in)

5
dave
laura
owen
vick
amr
dave
200 3
laura
owen
vick
owen
500 1
dave
amr
150 2
vick
owen
laura
0 2
amr
vick
vick
0 0

OUTPUT FORMAT

The output is NP lines, each with the name of a person followed by a single blank followed by the net gain or loss (final_money_value - initial_money_value) for that person. The names should be printed in the same order they appear on line 2 of the input.

All gifts are integers. Each person gives the same integer amount of money to each friend to whom any money is given, and gives as much as possible that meets this constraint. Any money not given is kept by the giver.

SAMPLE OUTPUT (file gift1.out)

dave 302
laura 66
owen -359
vick 141
amr -150


题目关键是注意readLine()的时候 读到哪了 ,第一行给出了一共有多少个人,即NP个人

接下来的NP行分别是NP个人的名字,再下来的一行就是要给别人钱的人的名字,下来就是金钱(money)和给钱人要发钱的人数(numberPeople)。接下来的numberPoeple行就是获得钱的人的名字。后面依此类推,用for语句

我的答案:

/*
ID: yang4521
LANG: JAVA
TASK: gift1
*/
import java.io.*;
import java.util.*;
class gift1 {
	
	public static void main(String[] args) throws IOException {
		
	    BufferedReader f = new BufferedReader(new FileReader("gift1.in"));                                   
	    PrintWriter out = new PrintWriter(new BufferedWriter(new FileWriter("gift1.out")));
	    int NP = Integer.parseInt(f.readLine());
	    ArrayList<String> listName = new ArrayList<String>();
	    
	    String name="";
	    for(int i=0;i<NP;i++)  //get the all name of giver
	    {
	    	name=f.readLine();
	    	listName.add(name);
	    }
	    int[] initialMoney = new int[NP];//initial_money_value
	    int[] finalMoney = new int[NP];  //final_money_value
		for(int i=0;i<NP;i++)
		{
			name=f.readLine();
			String MoneyandNumber="";
			MoneyandNumber=f.readLine();//get the money and the number of people
			String[] strs =MoneyandNumber.split(" ");
			int money=Integer.parseInt(strs[0]);
			int numberPeople=Integer.parseInt(strs[1]);
			int average=0;
			int leftOver=0;
		    if(numberPeople!=0)
			{	
		    	 average=money/numberPeople;
		    	 leftOver=money%numberPeople;
			}
		
			for(int j = 0;j<listName.size();j++)//
			{
			  if(listName.get(j).equals(name))//giver name
			  {
				  initialMoney[j]=money;
				  finalMoney[j]+=leftOver;
			  }
			}
			for(int k=0;k<numberPeople;k++)//give the money to the people
			{
				name=f.readLine();
				for(int jj = 0;jj<listName.size();jj++)
				{
				  if(listName.get(jj).equals(name))//
				  {
					  finalMoney[jj]+=average;
				  }
				}
			}		
		}
		for(int i=0;i<NP;i++)
		{   
			out.print(listName.get(i)+" ");
			out.println(finalMoney[i]-initialMoney[i]);
		}
	    out.close();  // close the output file
	    System.exit(0);
	  }

}


官方的答案:

Analysis:
Greedy Gift Givers
Russ Cox

The hardest part about this problem is dealing with the strings representing people's names.

We keep an array of Person structures that contain their name and how much money they give/get.

The heart of the program is the lookup() function that, given a person's name, returns their Person structure. We add new people with addperson().

Note that we assume names are reasonably short.

#include <stdio.h>
#include <string.h>
#include <assert.h>

#define MAXPEOPLE 10
#define NAMELEN	32

typedef struct Person Person;
struct Person {
    char name[NAMELEN];
    int total;
};

Person people[MAXPEOPLE];
int npeople;

void
addperson(char *name)
{
    assert(npeople < MAXPEOPLE);
	strcpy(people[npeople].name, name);
    npeople++;
}

Person*
lookup(char *name)
{
    int i;

    /* look for name in people table */
    for(i=0; i<npeople; i++)
	if(strcmp(name, people[i].name) == 0)
	    return &people[i];

    assert(0);	/* should have found name */
}

int
main(void)
{
    char name[NAMELEN];
    FILE *fin, *fout;
    int i, j, np, amt, ng;
    Person *giver, *receiver;

    fin = fopen("gift1.in", "r");
    fout = fopen("gift1.out", "w");

    fscanf(fin, "%d", &np);
    assert(np <= MAXPEOPLE);

    for(i=0; i<np; i++) {
	fscanf(fin, "%s", name);
	addperson(name);
    }

    /* process gift lines */
    for(i=0; i<np; i++) {
	fscanf(fin, "%s %d %d", name, &amt, &ng);
	giver = lookup(name);

	for(j=0; j<ng; j++) {
	    fscanf(fin, "%s", name);
	    receiver = lookup(name);
	    giver->total -= amt/ng;
	    receiver->total += amt/ng;
	}
    }

    /* print gift totals */
    for(i=0; i<np; i++)
	fprintf(fout, "%s %d\n", people[i].name, people[i].total);
    exit (0);
}

你可能感兴趣的:(USACO,greedy,Gift,Givers)