hdoj A+B for Input-Output Practice (IV)

Problem Description

Your task is to Calculate the sum of some integers.

Input

Input contains multiple test cases. Each test case contains a integer N, and then N integers follow in the same line. A test case starting with 0 terminates the input and this test case is not to be processed.

Output

For each group of input integers you should output their sum in one line, and with one line of output for each line in input.

Sample Input

4 1 2 3 4
5 1 2 3 4 5
0 

Sample Output

10
15
代码:
#include<stdio.h>
int main()
{
    int n,a,sum=0;
    while(scanf("%d",&n)&&n)
    {
        while(n--)
        {
        scanf("%d",&a);
           sum=sum+a;
       }
           printf("%d\n",sum);
           sum=0;
   }
   return 0; 
}
注意:题目要求n=0时结束

你可能感兴趣的:(hdoj A+B for Input-Output Practice (IV))