POJ--2421--Constructing Roads


Constructing Roads Crawling in process... Crawling failed Time Limit:2000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status Practice POJ 2421
Appoint description: System Crawler (2015-11-10)

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j.

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179
 
    
题意:给出一个矩阵,并建好一些路,求还需多少费用是所有点连通,要求费用最少。
 
    
思路:用 Kruskal 求的话需将已经建立的边标记访问,将没建立的边存入边数组,进行最小生成树的构造;
     
     用 prim 求的话需将边权值为0的边改化为无穷大,再将已建立的边权值初始化为0,构造最小生成树。
Kruskal:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
#define max 102
int father[max], road[max][max], vis[max][max], n, k;
using namespace std;
struct edge
{
	int u, v, w;
}cost[max*max];
bool cmp(const edge& a, const edge& b)
{
	return a.w < b.w;
}
int find(int h)
{
	return h == father[h] ? h : father[h] = find(father[h]);
}
void add(int u, int v)//加边
{
	cost[k].u=u;
	cost[k].v=v;
	cost[k++].w=road[u][v];
}
int kruskal()
{
	int i, j, ans=0;
	sort(cost, cost+k, cmp);
	for(i=0;i<k;i++){
		int x=find(cost[i].u);
		int y=find(cost[i].v);
		if(x != y){
			ans+=cost[i].w;
			father[x]=y;
		}
	}
	return ans;
}
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int i, j, u, v, q;
	while(~scanf("%d", &n)){
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				scanf("%d", &road[i][j]);
			}
		}
		memset(vis, 0, sizeof(vis));
		for(i=1;i<=n;i++)
			father[i]=i;
		scanf("%d", &q);
		while(q--){
			scanf("%d %d", &u, &v);
			vis[u][v]=vis[v][u]=1; //标记访问
			int x=find(u), y=find(v); 
			if(x != y){
				father[x]=y;
			}
		}
		k=0;
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				if(!vis[i][j])   add(i, j);		//加未建立的边		
			}
		}
		printf("%d\n", kruskal());
	}
	return 0;
}

prim:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define INF 0x3f3f3f3f
int road[102][102], vis[102], mincost[102], n;
int prim()//精简写法!
{
	int i, j, v, cost=0;
	mincost[1]=0;
	while(true){ 
		v=-1;
		for(i=1;i<=n;i++){
			if(!vis[i]&&(v==-1||mincost[i]<mincost[v]))//找最小值
				v=i;
		}
		if(v==-1)  break;
		vis[v]=1;  //标记访问
		cost+=mincost[v];
		for(j=1;j<=n;j++){
			if(!vis[j]&&road[v][j]<mincost[j])
				mincost[j]=road[v][j];//更新最小值
		}
	}
	return cost;  
}
using namespace std;
int main()
{
#ifdef OFFLINE
	freopen("t.txt","r",stdin);
#endif
	int i, j, u, v, q, zero;
	while(~scanf("%d", &n)){
		memset(road, INF, sizeof(road));//需初始化为无穷大
		memset(mincost, INF, sizeof(mincost));
		memset(vis, 0, sizeof(vis));
		for(i=1;i<=n;i++){
			for(j=1;j<=n;j++){
				if(i==j) {
					scanf("%d", &zero);   continue;//输入0不赋值为0
				}
				scanf("%d", &road[i][j]);
			}
		}
		scanf("%d", &q);
		while(q--){
			scanf("%d %d", &u, &v);
			road[u][v]=road[v][u]=0;//已经建立的路权值置为0
		}
		printf("%d\n", prim());
	}
	return 0;
}

 
   

你可能感兴趣的:(图论)