HDU 1302 The Snail(模拟题)

The Snail

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2224    Accepted Submission(s): 1581


Problem Description
A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.

Day Initial Height Distance Climbed Height After Climbing Height After Sliding
1 0 3 3 2
2 2 2.7 4.7 3.7
3 3.7 2.4 6.1 -

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.
 

Input
The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.
 

Output
For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.
 

Sample Input
   
   
   
   
6 3 1 10 10 2 1 50 50 5 3 14 50 6 4 1 50 6 3 1 1 1 1 1 0 0 0 0
 

Sample Output
   
   
   
   
success on day 3 failure on day 4 failure on day 7 failure on day 68 success on day 20 failure on day 2
 

题解:有一条蛇爬**,白天爬U高度,晚上降下D高度,F是蛇的疲劳度,关系是每天爬的速率降为为U*F(F为百分率)。。。。然后计算多少天可以爬出去****或者根本爬不出去。。。

AC代码:

#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<algorithm>
typedef long long LL;
using namespace std;

int main()
{
	double h,u,d,f; //f为速度下降的概率,计算出每次速度下降的大小为u*f 
	while(cin>>h>>u>>d>>f){
		if(h==0&&u==0&&d==0&&f==0)break;
		
		 int flag=0;
		double dis=0;
		 int day=1;
		 double s=u*(f/100.0);
		 		 
		while(dis>=0&&dis<=h){
			if(u>0)
			dis+=u;
			if(dis>h){
				flag=1;
				break;
			}
			dis-=d;
			if(dis<0)
			{
				break;
			}
			u-=s;
			day++;
		}
		if(flag)
            cout<<"success on day "<<day<<endl;
        else
            cout<<"failure on day "<<day<<endl;
	}
     return 0;
}


你可能感兴趣的:(HDU,the,1302,模拟题,Snail)