HDU 4497 GCD and LCM (素数筛选+算术基本定理)

     算术基本定理可表述为:任何一个大于1的自然数 N,如果N不为质数,那么N可以唯一分解成有限个质数的乘积N=P1a1P2a2P3a3......Pnan,这里P1<P2<P3......<Pn均为质数,其中指数ai是正整数。这样的分解称为 的标准分解式。最早证明是由欧几里得给出的,现代是由陈述证明。此定理可推广至更一般的交换代数代数数论


 

lcm(x,y,z)=k;

gcd(x,y,z)=t;

若:x=a*t;   y=b*t;       z=c*t;

则lcm(a,b,c)=k/t;

若k/t=2^A;

则a,b,c中至少有一个数为2^A,至少有一个数是2^0,另外一个数为2^(0~A);共6*A种情况。

则,若k/t=2^A*3^B*5^C;

a,b,c的情况数为:(6*A)*(6*B)*(6*C);


GCD and LCM

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1978    Accepted Submission(s): 876


Problem Description
Given two positive integers G and L, could you tell me how many solutions of (x, y, z) there are, satisfying that gcd(x, y, z) = G and lcm(x, y, z) = L? 
Note, gcd(x, y, z) means the greatest common divisor of x, y and z, while lcm(x, y, z) means the least common multiple of x, y and z. 
Note 2, (1, 2, 3) and (1, 3, 2) are two different solutions.
 

Input
First line comes an integer T (T <= 12), telling the number of test cases. 
The next T lines, each contains two positive 32-bit signed integers, G and L. 
It’s guaranteed that each answer will fit in a 32-bit signed integer.
 

Output
For each test case, print one line with the number of solutions satisfying the conditions above.
 

Sample Input
   
   
   
   
2 6 72 7 33
 

Sample Output
   
   
   
   
72 0
 

Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现
 
#include <iostream>
#include <cstring>
using namespace std;
const int max_num = 1000000;

int vis[max_num],prim[max_num];
int len;
int sum;

void is_prim()
{
	len = 0;
	memset(vis,0,sizeof(vis));
	memset(prim,0,sizeof(prim));
	for(int i=2;i<max_num;i++)
	{
		if(!vis[i])
		{
			prim[len++] = i;
			for(int j=2*i;j<max_num;j+=i)
			{
				vis[j] = 1;
			}
		}
	}
}

int getPrim(int nn)
{
	int i;
	int s = 0;
	sum = 1;
	for(i=0;i<len && prim[i]*prim[i]<=nn;i++)
	{	
		s=0;
		while(nn%prim[i]==0)
		{
			s += 6;
			nn/=prim[i];
		}

		if(s)
		sum *= s;
	}
	
	if(nn > 1)
		sum *= 6;
	return sum;
}

int main()
{
	int i,j,k,m,n;
	int t;
	int g,l;

	is_prim();
	cin>>t;
	while(t--)
	{
		cin>>g>>l;
		if(l%g)
		{
			cout<<"0"<<endl;
			continue;
		}
		
		cout<<getPrim(l/g)<<endl;
	}
	return 0;
}


你可能感兴趣的:(HDU 4497 GCD and LCM (素数筛选+算术基本定理))