HDU 1162Eddy's picture(prim)

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8714    Accepted Submission(s): 4427


Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?
 

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.
 

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.
 

Sample Input
   
   
   
   
3 1.0 1.0 2.0 2.0 2.0 4.0
 

Sample Output
   
   
   
   
3.41
 

Author
eddy
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:   1102  1217  1142  1879  1213 
 给你点的坐标,求把这些点连起来的最短路径,简单的最小生成树,好长时间没写最小生成树prim算法了,有点生疏了。。。。
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
#define INF 0xfffffff
using namespace std;
double map[110][110],sum;
int n;
void prim()
{
	sum=0.0;
	double dis[2100],min;
	int i,j,k,visit[2100];
	memset(visit,0,sizeof(visit));
	for(i=1;i<=n;i++)
	dis[i]=map[1][i];
	visit[1]=1;
	for(i=2;i<=n;i++)
	{
		min=INF;
		for(j=1;j<=n;j++)
		{
			if(!visit[j]&&min>dis[j])
			{
				min=dis[j];
				k=j;
			}
		}
		sum+=min;
		visit[k]=1;
		for(j=1;j<=n;j++)
		{
			if(!visit[j]&&dis[j]>map[k][j])
			{
				dis[j]=map[k][j];
			}
		}
	}
	printf("%.2lf\n",sum);
}
double distance(double x1,double x2,double y1,double y2)
{
	return sqrt((x1-x2)*(x1-x2)+(y1-y2)*(y1-y2));
}
int main()
{
	double x[2100],y[2100];
	int i,j;
	while(scanf("%d",&n)!=EOF)
	{
		memset(map,INF,sizeof(map));
		for(i=1;i<=n;i++)
		scanf("%lf%lf",&x[i],&y[i]);
		for(i=1;i<=n;i++)
		for(j=i+1;j<=n;j++)
		{
			map[i][j]=map[j][i]=distance(x[i],x[j],y[i],y[j]);
		}
		prim();
	}
	return 0;
}




你可能感兴趣的:(HDU 1162Eddy's picture(prim))