题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=3714
Error Curves
Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 4536 Accepted Submission(s): 1721
Problem Description
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm's efficiency, she collects many datasets.
What's more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset's test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.
It's very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function's minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1...n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it's too hard for her to solve this problem. As a super programmer, can you help her?
Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.
Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.
Sample Input
Sample Output
Author
LIN, Yue
Source
2010 Asia Chengdu Regional Contest
Recommend
zhouzeyong
思路:单峰函数求极值问题。三分定义域[0,1000],求解答案。注意:精度卡得比较严格。
直接附上AC代码:
#include <bits/stdc++.h>
//#pragma comment(linker, "/STACK:102400000, 102400000")
using namespace std;
const int maxn = 10005;
const int inf = 0x3f3f3f3f;
const double eps = 1e-9;
int a[maxn], b[maxn], c[maxn];
int n;
double func(double x){
double maxnum=-inf, f;
for (int i=0; i<n; ++i){
f = a[i]*x*x+b[i]*x+c[i];
maxnum = max(maxnum, f);
}
return maxnum;
}
int main(){
#ifdef LOCAL
freopen("input.txt", "r", stdin);
freopen("output.txt", "w", stdout);
#endif
int T;
scanf("%d", &T);
while (T--){
scanf("%d", &n);
for (int i=0; i<n; ++i)
scanf("%d%d%d", a+i, b+i, c+i);
double l=0.0, r=1000.0, mid, tri;
while (r-l > eps){
mid = (r+l)/2.0;
tri = (r+mid)/2.0;
if (func(mid) > func(tri))
l = mid;
else
r = tri;
}
double ans = func(l);
printf("%.4f\n", ans);
}
return 0;
}