1133搜索(三)

题目

  • Description

给定整数序列,查询多个整数是否存在。

  • Input

输入多行:

l 第1行给出整数序列大小n,查询次数m(待查询的整数可以重复), 1≤n≤100000,1≤m≤100000

l 第2行给出整数序列,每个整数绝对值不超1000000

l m行,每1行给出指定整数

  • Output

对于每个测试用例:

l 输出m行,每1行给出一个查询结果,指定整数存在则输出“Yes”,否则输出“No”

注意:输出部分的结尾要求包含一个多余的空行。

  • Sample Input

2 2
1 2
2
3

  • Sample Output

Yes
No

#include<iostream>
using namespace std;
#define N 1000000
int used[N*2+10];
int main()
{
    int n,m,i,x;
    freopen("D://in.txt","r",stdin);
    scanf("%d%d",&n,&m);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&x);
        used[x+N]=1;
    }
    for(i=1;i<=m;i++)
    {
        scanf("%d",&x);
        if(used[x+N])
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}

你可能感兴趣的:(1133搜索(三))