UVA-129 Krypton Factor(dfs)

题目链接:

UVA-129 Krypton Factor(dfs)

题目大意:

如果一个字符串包含两个相邻的重复子串,则成它是"容易的串",其他串成为"困难的串"例如: BB ,ABCDACABCAB , ABCDABCD 都是容易串,而 D, DC, ABDAB, CBABCBA, 都是困难串.
输入正整数n, l 输出由前l个大写字母组成的,字典序第n小的困难串,例如:
当l=3,n=7, 前7个困难串分别是:
A, AB, ABA, ABAC, ANACA, ABACAB, ABACABA,,所以第七个为 ABACABA

输出奇葩:

四个一组,中间有空格,16组一个换行,没空格,最后一行,单独打印有字符串长度.

Description

You have been employed by the organisers of a Super Krypton Factor Contest in which contestants have very high mental and physical abilities. In one section of the contest the contestants are tested on their ability to recall a sequence of characters which has been read to them by the Quiz Master. Many of the contestants are very good at recognising patterns. Therefore, in order to add some difficulty to this test, the organisers have decided that sequences containing certain types of repeated subsequences should not be used. However, they do not wish to remove all subsequences that are repeated, since in that case no single character could be repeated. This in itself would make the problem too easy for the contestants. Instead it is decided to eliminate all sequences containing an occurrence of two adjoining identical subsequences. Sequences containing such an occurrence will be called easy''. Other sequences will be calledhard”.

For example, the sequence ABACBCBAD is easy, since it contains an adjoining repetition of the subsequence CB. Other examples of easy sequences are:

BB
ABCDACABCAB
ABCDABCD 

Some examples of hard sequences are:

D
DC
ABDAB
CBABCBA 

Input and Output

In order to provide the Quiz Master with a potentially unlimited source of questions you are asked to write a program that will read input lines that contain integers n and L (in that order), where n > 0 and L is in the range tex2html_wrap_inline39 , and for each input line prints out the nth hard sequence (composed of letters drawn from the first L letters in the alphabet), in increasing alphabetical order (alphabetical ordering here corresponds to the normal ordering encountered in a dictionary), followed (on the next line) by the length of that sequence. The first sequence in this ordering is A. You may assume that for given n and L there do exist at least n hard sequences.

For example, with L = 3, the first 7 hard sequences are:

A
AB
ABA
ABAC
ABACA
ABACAB
ABACABA 

As each sequence is potentially very long, split it into groups of four (4) characters separated by a space. If there are more than 16 such groups, please start a new line for the 17th group.

Therefore, if the integers 7 and 3 appear on an input line, the output lines produced should be

ABAC ABA
7

Input is terminated by a line containing two zeroes. Your program may assume a maximum sequence length of 80.

Sample Input

30 3
0 0

Sample Output

ABAC ABCA CBAB CABA CABC ACBA CABA
28

思路分析:

基本框架:从左到右依次考虑每个位置上的字符.因此,问题的关键在于如何判断当前字符串是否已经存在连续的重复子串,例如,如何判断abacaba是否包含连续的重复子串呢? 一种方法是检查所有长度为偶数的子串,分别判断每个字符串的前一半是否等于后一半,尽管是正确的,但是做了许多无用功,其实我们只需要判断当前串的后缀(加入某字母后),而非所有子串,如果是困难串,将字母添加,不是,尝试下一个字母

code:

/************************************************************************* > File Name: uva_129.cpp > Author: dulun > Mail: [email protected] > Created Time: 2016年04月14日 星期四 14时50分03秒 ************************************************************************/

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#define LL long long
using namespace std;

int n, l;
const int N = 50086;
int a[N];
int s[N];
int cnt = 0;

bool dfs(int cur)
{
    if(cnt++ == n)
    {
        for(int i = 0; i < cur; i++)
        {
            if(i && i % 64 == 0) printf("\n");
            else if(i && i % 4 == 0) printf(" ");
            printf("%c", 'A' + s[i]);
        }
        printf("\n%d\n", cur);
        return 0;
    }

    for(int i = 0; i < l; i++)
    {
        s[cur] = i;
        int ok = 1;
        for(int j = 1; j * 2 <= cur+1; j++)
        {
            int equal = 1;
            for(int k = 0; k < j; k++)
                if(s[cur-k] != s[cur-k-j]) {equal = 0; break;}
            if(equal) {ok = 0; break;}
        }
        if(ok)
        {
            if(!dfs(cur+1)) return 0;
        }
    }
    return 1;
}

int main()
{
    while(~scanf("%d%d", &n, &l) && n+l)
    {
        cnt = 0;
        dfs(0);
    }

    return 0;
}

你可能感兴趣的:(DFS,uva)