HDU 5317 RGCDQ

Problem Description
Mr. Hdu is interested in Greatest Common Divisor (GCD). He wants to find more and more interesting things about GCD. Today He comes up with Range Greatest Common Divisor Query (RGCDQ). What’s RGCDQ? Please let me explain it to you gradually. For a positive integer x, F(x) indicates the number of kind of prime factor of x. For example F(2)=1. F(10)=2, because 10=2*5. F(12)=2, because 12=2*2*3, there are two kinds of prime factor. For each query, we will get an interval [L, R], Hdu wants to know  maxGCD(F(i),F(j))   (Li<jR)
 

Input
There are multiple queries. In the first line of the input file there is an integer T indicates the number of queries.
In the next T lines, each line contains L, R which is mentioned above.

All input items are integers.
1<= T <= 1000000
2<=L < R<=1000000
 

Output
For each query,output the answer in a single line. 
See the sample for more details.
 

Sample Input
   
   
   
   
2 2 3 3 5
 

Sample Output
   
   
   
   
1 1
 


预处理出全部数字的F(x)值,

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000005;
int T,n,m,f[maxn],p[maxn],tot=0,l,r,u[maxn][8];

void pre()
{
    for (int i=2;i<maxn;i++)
    {
        if (!f[i]) p[tot++]=i;
        for (int j=0;j<tot;j++)
        {
            if (p[j]*i>=maxn) break;
            f[p[j]*i]=1;
            if (i%p[j]==0) break;
        }
    }
    memset(f,0,sizeof(f));
    int ans=0;
    for (int i=2;i<maxn;i++)
    {
        int j,k;
        for (j=0,k=i;j<tot&&p[j]*p[j]<=i;j++)
        {
            if (k%p[j]==0) f[i]++;
            while (k%p[j]==0) k/=p[j];
        }
        if (k>1) f[i]++;
        for (j=1;j<=7;j++) u[i][j]=u[i-1][j];
        u[i][f[i]]++;
    }
}

int main()
{
    pre();
    scanf("%d",&T);
    while (T--)
    {
        scanf("%d%d",&l,&r);
        for (int i=1;i<=7;i++) u[0][i]=u[r][i]-u[l-1][i];
        int flag=1;
        for (int i=7;i>=2&&flag;i--) 
        if (u[0][i]>1) 
        {
            printf("%d\n",i); flag=0;
        }
        else 
        {
            if (i==3&&u[0][3]+u[0][6]>1)
            {
                printf("%d\n",i); flag=0;
            }
            else if (i==2&&u[0][2]+u[0][6]+u[0][4]>1)
            {
                printf("%d\n",i); flag=0;
            }
        }
        if (flag) printf("1\n");
    }
    return 0;
}

你可能感兴趣的:(HDU)