有关优先对列的题——UVA12100 - Printer Queue

原题如下:

The only printer in the computer science students'union is experiencing an extremely heavy workload.Sometimes there are a hundred jobs in the printerqueue and you may have to wait for hours to get a single page of output.

Because some jobs are more important than others,the Hacker General has invented and implemented a simple priority system for the print job queue. Now,each job is assigned a priority between 1 and 9 (with 9 being the highest priority, and 1 being the lowest), and the printer operates as follows. 
 The first job J in queue is taken from the queue.
 If there is some job in the queue with a higher priority than job J, then move J to the end of the
queue without printing it.
 Otherwise, print job J (and do not put it back in the queue).
In this way, all those important muffin recipes that the Hacker General is printing get printed very
quickly. Of course, those annoying term papers that others are printing may have to wait for quite
some time to get printed, but that's life.
Your problem with the new policy is that it has become quite tricky to determine when your print
job will actually be completed. You decide to write a program to gure this out. The program will
be given the current queue (as a list of priorities) as well as the position of your job in the queue, and
must then calculate how long it will take until your job is printed, assuming that no additional jobs
will be added to the queue. To simplify matters, we assume that printing a job always takes exactly one minute, and that adding and removing jobs from the queue is instantaneous.

Input
One line with a positive integer: the number of test cases (at most 100). Then for each test case:
 One line with two integers n and m, where n is the number of jobs in the queue (1  n  100)
and m is the position of your job
(0  <=m <= n - 1). The rst position in the queue is number 0,
the second is number 1, and so on.
 One line with n integers in the range 1 to 9, giving the priorities of the jobs in the queue. The
rst integer gives the priority of the rst job, the second integer the priority of the second job,
and so on.
Output
For each test case, print one line with a single integer; the number of minutes until your job is completely
printed, assuming that no additional print jobs will arrive.
Sample Input
3
1 0
5
4 2
1 2 3 4
6 0
1 1 9 1 1 1
Sample Output
1
2
5

题目大意如下:

学校打印机有很多任务要打印,但是每个任务的重要性不同。打印机打印的规则是如果当前打印打印队列有比现在要打印的队列急,那么就把当前任务放到队尾,否则打印此任务,输出的是打印队列开始时关注位置的任务打印的时间。

题目分析:

我们可以才用一个优先对列和一个队列存储打印任务,如果它们的对首元素相同那就输出,否则出队列,之后在进队列。

代码如下:

#include <iostream>
#include <queue>
using namespace std;
struct cmp
{
    bool operator()(const int a, const int b)const
    {
        return a < b;
    }
};
int main()
{
    int t;
    cin >> t;
    while(t--)
    {
        int n, m;
        queue<int> q;
        priority_queue<int, vector<int>, cmp> pq;
        cin >> n >> m;
        for(int i=0;i<n;i++)
        {
            int rate;
            cin>>rate;
            pq.push(rate);
            q.push(rate);
        }
        int x = 0;
        while(true)
        {
            if(q.front()==pq.top())
            {
                if(x==m)
                {
                    cout<<n-q.size()+1<<endl;
                    break;
                }
                else
                {
                    q.pop();
                    pq.pop();
                    x++;
                }
            }
            else
            {
                int temp = q.front();
                q.pop();
                q.push(temp);
                if(x==m)
                {
                    x=0;
                    m=q.size()-1;
                }
                else
                {
                    x++;
                }
            }
        }
    }
    return 0;
}


你可能感兴趣的:(C++,uva,X,operator,优先对列)