Eight
Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17098 Accepted Submission(s): 4702
Special Judge
Problem Description
The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:
1 2 3 4
5 6 7 8
9 10 11 12
13 14 15 x
where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:
1 2 3 4 1 2 3 4 1 2 3 4 1 2 3 4
5 6 7 8 5 6 7 8 5 6 7 8 5 6 7 8
9 x 10 12 9 10 x 12 9 10 11 12 9 10 11 12
13 14 11 15 13 14 11 15 13 14 x 15 13 14 15 x
r-> d-> r->
The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.
Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).
In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.
Input
You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle
1 2 3
x 4 6
7 5 8
is described by this list:
1 2 3 x 4 6 7 5 8
Output
You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.
Sample Input
Sample Output
Source
South Central USA 1998 (Sepcial Judge Module By JGShining)
Recommend
JGShining | We have carefully selected several similar problems for you: 1044 1072 1180 1401 1195
八段码,搜索入坑第一题。第一个是单广加打表,状态的存储用康拓定理。
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define maxn 400000
#define aim 46234
using namespace std;
int vis[maxn];
char d[4]={'d','u','r','l'};
int dx[4]={-1,1,0,0};
int dy[4]={0,0,-1,1};
struct node{
int loc;
int s[9];
char dir;
int status;
int fa;
}n[maxn];
char path[maxn][40];
int fac[10] = { 1, 1, 2, 6, 24, 120, 720, 5040, 40320, 362880 };
int inverse_cantor(int s[9])
{
int sum=0,num=0;
for(int i=0;i<9;i++)
{
num=0;
for(int j=i+1;j<9;j++)
{
if(s[j]<s[i])
num++;
}
sum+=num*fac[8-i];
}
return sum+1;
}
void count_path(node a)
{
int status=a.status;
int f=a.fa;
int num=0;
path[status][num++]=a.dir;
while(f)
{
path[status][num++]=n[f].dir;
f=n[f].fa;
}
}
void bfs()
{
memset(vis,0,sizeof(vis));
node next;
for(int i=0;i<8;i++)
n[0].s[i]=i+1;
n[0].s[8]=0;
n[0].status=aim;
n[0].loc=8;
vis[aim]=1;
int head=0,tail=0;
while(head<=tail)
{
int x=n[head].loc/3;
int y=n[head].loc%3;
for(int i=0;i<4;i++)
{
int tx=x+dx[i];
int ty=y+dy[i];
if(tx<0||tx>2||ty<0||ty>2) continue;
next=n[head];
next.dir=d[i];
next.fa=head;
next.loc=3*tx+ty;
next.s[n[head].loc]=next.s[next.loc];
next.s[next.loc]=0;
next.status=inverse_cantor(next.s);
if(vis[next.status]==0)
{
vis[next.status]=1;
count_path(next);
n[++tail]=next;
}
}
head++;
}
}
int main()
{
bfs();
int sum=0;
char ch[3];
node cur;
while(scanf("%s",ch)!=EOF)
{
if(ch[0]=='x')
{
cur.s[0]=0;
cur.loc=0;
}
else cur.s[0]=ch[0]-'0';
for(int i=1;i<9;i++)
{
scanf("%s",ch);
{
if(ch[0]=='x')
{
cur.s[i]=0;cur.loc=i;
}
else cur.s[i]=ch[0]-'0';
}
}
cur.status=inverse_cantor(cur.s);
if(vis[cur.status]==1)
printf("%s\n",path[cur.status]);
else printf("unsolvable\n");
}
return 0;
}
第二个是IDA*
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char op[4]={'u','r','d','l'};
int maze[4][4];
char ip[11];
int pos[9][2] = {
{0,0},{0,1},{0,2},
{1,0},{1,1},{1,2},
{2,0},{2,1},{2,2}
};
int count_step[50];
int limit,ok;
int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
int h(int x,int y)
{
int num=0;
for(int i=0;i<3;i++)
{
for(int j=0;j<3;j++)
{
if(i!=x||j!=y)
{
num+=abs(i-pos[maze[i][j]-1][0]);
num+=abs(j-pos[maze[i][j]-1][1]);
}
}
}
return num;
}
int judge()
{
int maze1[10],k=0,sum=0;
for(int i=0;i<3;i++)
{
for(int j=0;j<3;j++)
{
if(maze[i][j]!=9)
{
maze1[++k]=maze[i][j];
}
}
}
for(int i=1;i<=8;i++)
{
for(int j=1;j<i;j++)
{
if(maze1[i]<maze1[j]) sum++;
}
}
if(sum&1) return 1;
else return 0;
}
int dfs(int x,int y,int step,int pre)
{
int hn=h(x,y);
if(hn==0)
{
ok=1;
return step;
}
if((hn+step)>limit) return hn+step;
int minn=1<<29;
for(int i=0;i<4;i++)
{
if(abs(i-pre)==2)continue;
int tx=x+dx[i];
int ty=y+dy[i];
if(tx<0||tx>=3||ty<0||ty>=3) continue;
count_step[step]=i;
swap(maze[x][y],maze[tx][ty]);
int tmp=dfs(tx,ty,step+1,i);
if(ok) return tmp;
minn=min(tmp,minn);
swap(maze[tx][ty],maze[x][y]);
}
return minn;
}
void ida(int x,int y)
{
ok=0;
memset(count_step,-1,sizeof(count_step));
while(ok==0&&limit<=30)
{
limit=dfs(x,y,0,-111);
}
if(ok==0)
{
cout<<"unsolvable"<<endl;
return ;
}
else
{
for(int i=0;i<limit;i++)
{
printf("%c",op[count_step[i]]);
}
cout<<endl;
return ;
}
}
int main()
{
while(cin>>ip[0])
{
for(int i=1;i<9;i++)
cin>>ip[i];
int x,y,t=0;
for(int i=0;i<3;i++)
{
for(int j=0;j<3;j++)
{
if(ip[t]=='x')
{
maze[i][j]=9;
x=i;y=j;
t++;
}
else maze[i][j]=ip[t++]-'0';
}
}
limit=h(x,y);
if(limit==0)
{
puts("");
continue;
}
if(judge())
{
puts("unsolvable");
}
else ida(x,y);
}
}
A*以后写