POJ 2686 Traveling by Stagecoach(状态压缩DP)

Traveling by Stagecoach
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 2780   Accepted: 999   Special Judge

Description

Once upon a time, there was a traveler. 

He plans to travel using stagecoaches (horse wagons). His starting point and destination are fixed, but he cannot determine his route. Your job in this problem is to write a program which determines the route for him. 

There are several cities in the country, and a road network connecting them. If there is a road between two cities, one can travel by a stagecoach from one of them to the other. A coach ticket is needed for a coach ride. The number of horses is specified in each of the tickets. Of course, with more horses, the coach runs faster. 

At the starting point, the traveler has a number of coach tickets. By considering these tickets and the information on the road network, you should find the best possible route that takes him to the destination in the shortest time. The usage of coach tickets should be taken into account. 

The following conditions are assumed. 
  • A coach ride takes the traveler from one city to another directly connected by a road. In other words, on each arrival to a city, he must change the coach. 
  • Only one ticket can be used for a coach ride between two cities directly connected by a road. 
  • Each ticket can be used only once. 
  • The time needed for a coach ride is the distance between two cities divided by the number of horses. 
  • The time needed for the coach change should be ignored.

Input

The input consists of multiple datasets, each in the following format. The last dataset is followed by a line containing five zeros (separated by a space). 

n m p a b 
t1 t2 ... tn 
x1 y1 z1 
x2 y2 z2 
... 
xp yp zp 

Every input item in a dataset is a non-negative integer. If a line contains two or more input items, they are separated by a space. 

n is the number of coach tickets. You can assume that the number of tickets is between 1 and 8. m is the number of cities in the network. You can assume that the number of cities is between 2 and 30. p is the number of roads between cities, which may be zero. 

a is the city index of the starting city. b is the city index of the destination city. a is not equal to b. You can assume that all city indices in a dataset (including the above two) are between 1 and m. 

The second line of a dataset gives the details of coach tickets. ti is the number of horses specified in the i-th coach ticket (1<=i<=n). You can assume that the number of horses is between 1 and 10. 

The following p lines give the details of roads between cities. The i-th road connects two cities with city indices xi and yi, and has a distance zi (1<=i<=p). You can assume that the distance is between 1 and 100. 

No two roads connect the same pair of cities. A road never connects a city with itself. Each road can be traveled in both directions.

Output

For each dataset in the input, one line should be output as specified below. An output line should not contain extra characters such as spaces. 

If the traveler can reach the destination, the time needed for the best route (a route with the shortest time) should be printed. The answer should not have an error greater than 0.001. You may output any number of digits after the decimal point, provided that the above accuracy condition is satisfied. 

If the traveler cannot reach the destination, the string "Impossible" should be printed. One cannot reach the destination either when there are no routes leading to the destination, or when the number of tickets is not sufficient. Note that the first letter of "Impossible" is in uppercase, while the other letters are in lowercase. 

Sample Input

3 4 3 1 4
3 1 2
1 2 10
2 3 30
3 4 20
2 4 4 2 1
3 1
2 3 3
1 3 3
4 1 2
4 2 5
2 4 3 4 1
5 5
1 2 10
2 3 10
3 4 10
1 2 0 1 2
1
8 5 10 1 5
2 7 1 8 4 5 6 3
1 2 5
2 3 4
3 4 7
4 5 3
1 3 25
2 4 23
3 5 22
1 4 45
2 5 51
1 5 99
0 0 0 0 0

Sample Output

30.000
3.667
Impossible
Impossible
2.856

Hint

Since the number of digits after the decimal point is not specified, the above result is not the only solution. For example, the following result is also acceptable. 

30.0

3.66667

Impossible

Impossible

2.85595


题意:有n张车票,m个城市,给出p条路径,每条路径有x,y,z三个元素。表示从x到y的路径长度为z。 给出a,b。商人要从a城市到达b城市。 每张车票只能通过一条道路,且每张车票上有车子的马的匹数。从一个城市到达它相邻的城市所需的时间等于城市之间的道路长度除以马的匹数。每张车票只能用一次,且不考虑换乘所需的时间。求城市a到城市b所需要的最短时间。 如果无法到达输出“Impossible”。


题解:在状态压缩dp中我们用二进制表示一个集合中的元素的选取与否。这样就可以用0  ~~  (1<<n)-1表示每一张票是否选取。  我们将dp[S][v]表示“现在在城市v,此时剩下的车票的集合为S” 。从这个状态出发使用一张车票i∈S移动到相邻的城市u,即相当于转移到了“在城市u,此时剩下的车票的集合为S\{i}”这个状态(dp[S\{i}][u])。 根据题意我们可以得到状态转移方程 dp[S][u] = min(dp[S][u],dp[S∪i][v]+map[v][u]/t[i])


代码如下:


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
int t[10];
int map[40][40];
double dp[300][40];//dp[S][v]:到达城市v,并且剩下的车票集合为S 
int main()
{
	int n,m,p,a,b,i,x,y,z;
	while(scanf("%d%d%d%d%d",&n,&m,&p,&a,&b)!=EOF)
	{
		if(n==0&&m==0&&p==0&&a==0&&b==0)
			break;
		for(i=0;i<n;++i)
			scanf("%d",&t[i]);
		memset(map,-1,sizeof(map));//初始化地图 
		while(p--)
		{
			scanf("%d%d%d",&x,&y,&z);
			map[x][y]=map[y][x]=z;
		}
		for(i=0;i < 1<<n;++i)
			fill(dp[i]+1,dp[i]+m+1,INF);//用足够大的值初始化,注意城市的编号从1到m 
		dp[(1<<n)-1][a]=0;
		double ans=INF;
		int v,u;
		for(int S=(1<<n)-1;S>=0;--S)
		{
			ans=min(ans,dp[S][b]);
			for(v=1;v<=m;++v)
			{
				for(i=0;i<n;++i)
				{
					if(S>>i&1)//表示当前编号为i的车票还没有被用到 
					{
						for(u=1;u<=m;++u)
						{
							if(map[v][u]>=0)
								dp[S& ~(1<<i)][u]=min(dp[S& ~(1<<i)][u],dp[S][v]+map[v][u]*1.0/t[i]);
						}
					}
				}
			}
		}
		if(ans==INF)
			printf("Impossible\n");
		else
			printf("%0.3f\n",ans);
	}
	return 0;
} 







你可能感兴趣的:(POJ 2686 Traveling by Stagecoach(状态压缩DP))