F - Nightmare

F - Nightmare
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit  Status

Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes. 

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1. 

Here are some rules: 
1. We can assume the labyrinth is a 2 array. 
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too. 
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth. 
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb. 
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish. 
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6. 
 

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. 
There are five integers which indicate the different type of area in the labyrinth: 
0: The area is a wall, Ignatius should not walk on it. 
1: The area contains nothing, Ignatius can walk on it. 
2: Ignatius' start position, Ignatius starts his escape from this position. 
3: The exit of the labyrinth, Ignatius' target position. 
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas. 
 

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1. 
 

Sample Input

      
      
      
      
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output

      
      
      
      
4 -1 13

 

身上有个定时炸弹(╯‵□′)╯炸弹!•••*~● 6时间爆炸,一步一时间, 若走到4就可以重新让定时炸弹回到6时间,

问走几步能从起点2走到终点3.

本来是想走一步标记一下,若走到4清前面所有的标记,结果发现若有极端情况8*8的迷宫全是4,要跑4s,绝对超时,

后来看了别人博客才知道,因为迷宫小,完全可以不标记做过的路,只标记4的位置,这样就不会TLE了,O(∩_∩)O哈哈~


#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int x1,y1,a[10][10],a1[10][10],fx[4][2]= {1,0,   -1,0,   0,1,   0,-1};
struct stu
{
    int x,y,step,leave;
    friend bool operator <(stu a ,stu b)
    {
        return a.step>b.step;
    }
} d;
int bfs(stu s)
{
    priority_queue<stu>q;
    q.push(s);
    stu t;
    while(!q.empty())
    {
        int i,j,k;
        s=q.top();
        q.pop();
        if(s.leave>1)
            for(i=0; i<4; i++)
            {
                t.x=s.x+fx[i][0];
                t.y=s.y+fx[i][1];
                if(a[t.x][t.y]==1)
                {
                    t.step=s.step+1;
                    t.leave=s.leave-1;
                    q.push(t);
                }
                if(a[t.x][t.y]==3)
                    return s.step+1;
                if(a[t.x][t.y]==4)
                {
                    t.leave=6;
                    a[t.x][t.y]=0;
                    t.step=s.step+1;
                    q.push(t);
                }
            }
    }
    return -1;
}
int main()
{
    int N;
    scanf("%d",&N);
    while(N--)
    {
        memset(a,0,sizeof(a));
        scanf("%d%d",&x1,&y1);
        int i,j;
        for(i=1; i<=x1; i++)
            for(j=1; j<=y1; j++)
            {
                scanf("%d",&a[i][j]);
                a1[i][j]=a[i][j];
                if(a[i][j]==2)
                    d.x=i,d.y=j;
            }
        d.step=0;
        d.leave=6;
        a[d.x][d.y]=0;
        printf("%d\n",bfs(d));
    }
}

你可能感兴趣的:(队列,广搜)