HDU 2122Ice_cream’s world III

Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
   
   
   
   
2 1 0 1 10 4 0
 

Sample Output
   
   
   
   
10 impossible
 



#include<stdio.h>

#include <iostream>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<list>
#include<vector>
#pragma comment(linker,"/STACK:102400000,102400000")
using namespace std;
#define MAX 10000
struct edge   
{
    int x;
    int y;
    int w;
};
edge e[MAX];
int father[MAX];

bool cmp(edge o1,edge o2)//排序降序
{
    return o1.w<o2.w;
}


void Make_Set(int x)//建立父节点
{
    father[x]=x;
}


int Find_Set(int x)//查找x元素所在的集合
{
    if(x!=father[x])
    {
        father[x]=Find_Set(father[x]);//回溯时压缩路径
    }
    return father[x];
}




int main()
{
    int n,m,x,y,w;
    int i,j,count;
    int sum;
    while(scanf("%d%d",&n,&m)!=-1)
    {
        count=0;
        sum=0;
        for(i=0;i<n;i++)
        Make_Set(i);
        for(i=0;i<m;i++)
        scanf("%d%d%d",&e[i].x,&e[i].y,&e[i].w);
        sort(e,e+m,cmp);
        for(i=0;i<m;i++)
        {
            x=Find_Set(e[i].x);
            y=Find_Set(e[i].y);
            if(x!=y)
            {
                count++;
                sum+=e[i].w;
                father[x]=y;
            }
        }
        if(count!=n-1)
        printf("impossible\n");
        else
        printf("%d\n",sum);
        printf("\n");
    }
    return 0;
}



















































你可能感兴趣的:(并查集)