BFS-POJ-3278-Catch That Cow

Catch That Cow
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u

Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

  • Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
  • Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17

Sample Output
4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

//
// main.cpp
// 简单搜索-C-Catch That Cow
//
// Created by 袁子涵 on 15/7/26.
// Copyright (c) 2015年 袁子涵. All rights reserved.
//

#include <string.h>
#include <iostream>

#define minof(a,b) ((a)>(b)?(b):(a))

using namespace std;

typedef struct node
{
    unsigned long int step;
    unsigned long int num;
}Node;

//队列
typedef struct queue
{
    unsigned long long int head;
    unsigned long long int tail;
    Node data[1000000];
}Queue;

unsigned long int N,K;
Queue q;
Node origin,final;
int map[1000010];

//初始化
void initqueue()
{
    q.head=0;
    q.tail=0;
}

//入队
void Enqueue(Node t)
{
    q.data[q.tail]=t;
    q.tail++;
}

//出队
Node Dequeue()
{
    return q.data[q.head++];
}

//判断空队列
int queueempty()
{
    if (q.head==q.tail) {
        return 0;
    }
    return 1;
}

//检查数范围
int checknum(unsigned long int a)
{
    if (a<=110000 && a>0 && map[a]==0) {
        return 1;
    }
    return 0;
}

void bfs()
{
    Node t,y;
    Enqueue(origin);
    while (queueempty()) {
        t=Dequeue();
        map[t.num]=1;
        if (t.num==final.num) {
            final.step=minof(final.step, t.step);
            break;
        }
        y.step=t.step+1;
        y.num=t.num+1;
        if (checknum(y.num)) {
            Enqueue(y);
        }
        y.num=t.num-1;
        if (checknum(y.num)) {
            Enqueue(y);
        }
        y.num=t.num*2;
        if (checknum(y.num)) {
            Enqueue(y);
        }
    }
}

int main()
{
    cin >> N >> K;
    initqueue();
    memset(map, 0, sizeof(map));
    origin.num=N;
    origin.step=0;
    final.step=100000;
    final.num=K;
    bfs();
    cout << final.step <<endl;

}

你可能感兴趣的:(c,bfs)