1000 of greedy strategy*

Problem Description
The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

1000 of greedy strategy*_第1张图片

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

1000 of greedy strategy*_第2张图片

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.
 

Input
The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.
 

Output
The output should contain the minimum time in minutes to complete the moving, one per line.
 

Sample Input
   
   
   
   
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output
   
   
   
   
10 20 30
 题目要求:如何分配搬运使搬运次数最小。
思路:1通过计算情况的重叠区间,找的区间的最大重叠数即为所求。
        2通过贪心算法每次搬运最大组以得到最小的搬运次数。
细节:1高到低的搬运需要换顺序。
        2压缩房间使两排转化为一排。(注:减一除以二和加一除以二没有区别。)
        3特别注意重叠房间一个的情况。
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<stdio.h>
#include<stdlib.h>
#include<math.h>
#include<string.h>
#include<string>
using namespace std;
#define maxn 460
int main()
{
    int t,i,n,b,e;
    scanf("%d",&t);
    while (t--)
    {
        int c[200]={0},m=0;
        scanf("%d",&n);
        while (n--)
        {
            scanf("%d%d",&b,&e);
            if (b>e)
            {
                i=b;
                b=e;
                e=i;
            }
            for (i=(b-1)/2;i<=(e-1)/2;++i)++c[i];
        }
        for (i=0;i<200;++i)if (m<c[i])m=c[i];
        printf("%d\n",10*m);
    }
    return 0;
}
思路二的解法试了好久没有过,先标记吧。


你可能感兴趣的:(1000 of greedy strategy*)