hdu149850 years, 50 colors(好题)

50 years, 50 colors

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1971    Accepted Submission(s): 1089



Problem Description
On Octorber 21st, HDU 50-year-celebration, 50-color balloons floating around the campus, it's so nice, isn't it? To celebrate this meaningful day, the ACM team of HDU hold some fuuny games. Especially, there will be a game named "crashing color balloons".

There will be a n*n matrix board on the ground, and each grid will have a color balloon in it.And the color of the ballon will be in the range of [1, 50].After the referee shouts "go!",you can begin to crash the balloons.Every time you can only choose one kind of balloon to crash, we define that the two balloons with the same color belong to the same kind.What's more, each time you can only choose a single row or column of balloon, and crash the balloons that with the color you had chosen. Of course, a lot of students are waiting to play this game, so we just give every student k times to crash the balloons.

Here comes the problem: which kind of balloon is impossible to be all crashed by a student in k times.

hdu149850 years, 50 colors(好题)_第1张图片
 

Input
There will be multiple input cases.Each test case begins with two integers n, k. n is the number of rows and columns of the balloons (1 <= n <= 100), and k is the times that ginving to each student(0 < k <= n).Follow a matrix A of n*n, where Aij denote the color of the ballon in the i row, j column.Input ends with n = k = 0.
 

Output
For each test case, print in ascending order all the colors of which are impossible to be crashed by a student in k times. If there is no choice, print "-1".
 

Sample Input
   
   
   
   
1 1 1 2 1 1 1 1 2 2 1 1 2 2 2 5 4 1 2 3 4 5 2 3 4 5 1 3 4 5 1 2 4 5 1 2 3 5 1 2 3 4 3 3 50 50 50 50 50 50 50 50 50 0 0
 

Sample Output
   
   
   
   
-1 1 2 1 2 3 4 5 -1
 

Author
8600

想了半天其实已经想到了行列分布,也想到了枚举颜色,但并没有想到行和列之间建二分图,
因为每个点都要取到,所以行和列之间的那条边一定要取到,这便是最小点覆盖
#include<bits/stdc++.h>
const int MAXN=12000;
const int MAXM=4000010;
struct Edge{
    int to,next;
}edge[MAXM];
int tot;
int mp[151][151];
bool used[MAXN];
int linker[MAXN];
int head[MAXN];

void init(){
    tot=0;
    memset(head,-1,sizeof(head));
}

void addedge(int u,int v){
    edge[tot].to=v;
    edge[tot].next=head[u];
    head[u]=tot++;
}

bool dfs(int u){
    for(int i=head[u];i!=-1;i=edge[i].next){
        int v=edge[i].to;
        if(!used[v]){
            used[v]=true;
            if(linker[v]==-1||dfs(linker[v])){
                linker[v]=u;
                return true;
            }
        }
    }
    return false;
}

int hungary(int n){
    memset(linker,-1,sizeof(linker));
    int ret=0;
    for(int u=1;u<=n;u++){
        memset(used,false,sizeof(used));
        if(dfs(u))
            ret++;
    }
    return ret;
}

int main(){
    int k,n,m;
    int u,v;
    while(scanf("%d%d",&n,&m)!=EOF){
        if(n==0&&m==0)
            break;
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++){
                scanf("%d",&mp[i][j]);
            }
        int flag=0;
        for(int k=1;k<=50;k++){
            init();
            for(int i=1;i<=n;i++){
                for(int j=1;j<=n;j++)
                    if(mp[i][j]==k){
                        addedge(i,j+n);
                    }
            }
            int ans=hungary(n);
            if(ans>m){
                if(flag==1)
                    printf(" %d",k);
                else{
                    flag=1;
                    printf("%d",k);
                }
            }
        }
        if(flag==1)
            printf("\n");
        else
            printf("-1\n");
    }
    return 0;
}
/*
3 2
6 7 8
8 7 6
8 7 6
*/


 

你可能感兴趣的:(hdu149850 years, 50 colors(好题))