hdu4287 Intelligent IME-字典树

Intelligent IME

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4213    Accepted Submission(s): 1976


Problem Description
  We all use cell phone today. And we must be familiar with the intelligent English input method on the cell phone. To be specific, the number buttons may correspond to some English letters respectively, as shown below:
  2 : a, b, c    3 : d, e, f    4 : g, h, i    5 : j, k, l    6 : m, n, o    
  7 : p, q, r, s  8 : t, u, v    9 : w, x, y, z
  When we want to input the word “wing”, we press the button 9, 4, 6, 4, then the input method will choose from an embedded dictionary, all words matching the input number sequence, such as “wing”, “whoi”, “zhog”. Here comes our question, given a dictionary, how many words in it match some input number sequences?
 

Input
  First is an integer T, indicating the number of test cases. Then T block follows, each of which is formatted like this:
  Two integer N (1 <= N <= 5000), M (1 <= M <= 5000), indicating the number of input number sequences and the number of words in the dictionary, respectively. Then comes N lines, each line contains a number sequence, consisting of no more than 6 digits. Then comes M lines, each line contains a letter string, consisting of no more than 6 lower letters. It is guaranteed that there are neither duplicated number sequences nor duplicated words.
 

Output
  For each input block, output N integers, indicating how many words in the dictionary match the corresponding number sequence, each integer per line.
 

Sample Input
   
   
   
   
1 3 5 46 64448 74 go in night might gn
 

Sample Output
   
   
   
   
3 2 0
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online

最后40s写出来的,结果qwq

Output Limit Exceed
 赛后瞄了眼代码发现没把测试输出的代码注释掉。。。
其实就是一个简单的字典树,水水就过了。

Output Limit Exceed

#include <cstdio>
#include <cstring>
#include <cctype>
#include <cmath>
#include <set>
#include <map>
#include <list>
#include <queue>
#include <deque>
#include <stack>
#include <string>
#include <bitset>
#include <vector>
#include <iostream>
#include <algorithm>
using namespace std;
//#pragma comment(linker, "/STACK:102400000,102400000")
const int INF=0x3f3f3f3f; struct node { int ens; struct node *nextt[10]; }; struct node *root; int n,m; char   a[5001][8],b[5001][8]; int ans[5001]; int sb[300]; struct node *newset() { struct node *p;
    //p=(struct node *)malloc (sizeof(struct node ));
    p=new(node); for(int i=0;i<11;i++) {
        p->nextt[i]=NULL; }
    p->ens=999999; return p; }; void insertt(int pla) { struct node *p;
    p=root; int len =strlen(a[pla]);
   // printf("%d ",len);
 for(int i=0;i<len;i++) { if(p->nextt[a[pla][i]-'0']==NULL)
            p->nextt[a[pla][i]-'0']=newset();
           // printf("%d i",i);
        p=p->nextt[a[pla][i]-'0']; }
    p->ens=pla; } void takee(int pla) { struct node *p;
    p=root; int len=strlen(b[pla]); for(int i=0;i<len;i++) { if(p->nextt[sb[b[pla][i]]]==NULL) { return ; }
        p=p->nextt[sb[b[pla][i]]]; } if(p->ens!=999999)
        ans[p->ens]++; } void clearr(node * root) { for(int i=0;i<11;i++) { if(root->nextt[i]!=NULL) {
            clearr(root->nextt[i]); } }
    free(root); } int main() {
    sb['a']=sb['b']=sb['c']=2;
    sb['d']=sb['e']=sb['f']=3;
    sb['g']=sb['h']=sb['i']=4;
    sb['j']=sb['k']=sb['l']=5;
    sb['m']=sb['n']=sb['o']=6;
    sb['p']=sb['q']=sb['r']=sb['s']=7;
    sb['t']=sb['u']=sb['v']=8;
    sb['w']=sb['x']=sb['y']=sb['z']=9; int t;
    scanf("%d",&t); while(t--) {
        root=newset();
        memset(ans,0,sizeof(ans));
       scanf("%d%d",&n,&m); for(int i=0;i<n;i++) {
           scanf("%s",a[i]);
           insertt(i); } for(int i=0;i<m;i++) {
           scanf("%s",b[i]);
           takee(i); } for(int i=0;i<n;i++)
        printf("%d\n",ans[i]);

          clearr(root); } return   0; }

Output Limit Exceed

你可能感兴趣的:(字典树)