2011

2011

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. <br>
 

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.<br>
 

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.<br>
 

Sample Input
   
   
   
   
1 1<br>*<br>3 5<br>*@*@*<br>**@**<br>*@*@*<br>1 8<br>@@****@*<br>5 5 <br>****@<br>*@@*@<br>*@**@<br>@@@*@<br>@@**@<br>0 0 <br>
 

Sample Output
   
   
   
   
0<br>1<br>2<br>2<br>
 

Source
Mid-Central USA 1997
题意:给出一幅地图,判断相邻,对角的油田有多少个

思路:根据题意可知,需要使用搜索算法。其实这题BFS和DFS应该都可以,最后采用了深搜。深搜的代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstdlib>
#include<string>
using namespace std; 
typedef long long ll;
const double pi=acos(-1.0);
char s[120][120];
int a[8]={-1,-1,0,1,1,1,0,-1};
int b[8]={0,1,1,1,0,-1,-1,-1};
void dfs(int i,int j){
	if(i<0 || j<0)
		return;
	if(s[i][j]=='@'){
		s[i][j]='*';
		for(int k=0;k<8;k++)
			dfs(i+a[k],j+b[k]);
	}
}

int main(){
	int m,n;
	while(scanf("%d%d",&m,&n)!=EOF && (m||n)){
		int i,j;
		for(i=0;i<m;i++)
			scanf("%s",s[i]);
		int ans=0;
		for(i=0;i<m;i++){
			for(j=0;j<n;j++){
				if(s[i][j]=='@'){
					ans++;
					dfs(i,j);
				}
			}
		}
		printf("%d\n",ans);
	}
	return 0;
}

你可能感兴趣的:(2011)