POJ 2256 Artificial Intelligence?(字符串处理)

题目描述:
Artificial Intelligence?
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 1369 Accepted: 657
Description

Physics teachers in high school often think that problems given as text are more demanding than pure computations. After all, the pupils have to read and understand the problem first!
So they don’t state a problem like “U=10V, I=5A, P=?” but rather like “You have an electrical circuit that contains a battery with a voltage of U=10V and a light-bulb. There’s an electrical current of I=5A through the bulb. Which power is generated in the bulb?”.
However, half of the pupils just don’t pay attention to the text anyway. They just extract from the text what is given: U=10V, I=5A. Then they think: “Which formulae do I know? Ah yes, P=U*I. Therefore P=10V*5A=500W. Finished.”
OK, this doesn’t always work, so these pupils are usually not the top scorers in physics tests. But at least this simple algorithm is usually good enough to pass the class. (Sad but true.)
Today we will check if a computer can pass a high school physics test. We will concentrate on the P-U-I type problems first. That means, problems in which two of power, voltage and current are given and the third is wanted.

Your job is to write a program that reads such a text problem and solves it according to the simple algorithm given above.
Input

The first line of the input will contain the number of test cases.
Each test case will consist of one line containing exactly two data fields and some additional arbitrary words. A data field will be of the form I=xA, U=xV or P=xW, where x is a real number. Directly before the unit (A,V or W) one of the prefixes m (milli), k (kilo) and M (Mega) may also occur. To summarize it: Data fields adhere to the following grammar:
DataField ::= Concept ‘=’ RealNumber [Prefix] Unit
Concept ::= ‘P’ | ‘U’ | ‘I’

Prefix ::= ‘m’ | ‘k’ | ‘M’

Unit ::= ‘W’ | ‘V’ | ‘A’

Additional assertions:
The equal sign (‘=’) will never occur in an other context than within a data field.
There is no whitespace (tabs,blanks) inside a data field.
Either P and U, P and I, or U and I will be given.

Output

For each test case, print three lines:
a line saying “Problem #k” where k is the number of the test case
a line giving the solution (voltage, power or current, dependent on what was given), written without a prefix and with two decimal places as shown in the sample output
a blank line
Sample Input

3
If the voltage is U=200V and the current is I=4.5A, which power is generated?
A light-bulb yields P=100W and the voltage is U=220V. Compute the current, please.
bla bla bla lightning strike I=2A bla bla bla P=2.5MW bla bla voltage?
Sample Output

Problem #1
P=900.00W

Problem #2
I=0.45A

Problem #3
U=1250000.00V

题目大意:
P=UI(物理公式),从一句话里分析出其中两个量,求另外一个

题目分析:
这道题想法很容易,就是筛除两个量就可以了,方法不唯一,我下面把自己的代码站上去给大家看看参考就好了,但是我看到了我队友的代码,写的很漂亮,对于这种字符串里找数字的题目处理起来很方便

代码:

#include "stdio.h"
#include "iostream"
#include "string"
using namespace std;
string s;
double fval(int begin)
{
    int i=begin+2;
    double res=0,times=1;
    bool flag=false;
    while(1)
    {
        if(s[i]=='A'||s[i]=='V'||s[i]=='W'){
            return res/times;
        }
        switch(s[i]){
            case 'm':{
                times*=1000;
                break;
            }
            case 'k':{
                res*=1000;
                break;
            }
            case 'M':{
                res*=1000000;
                break;
            }
            case '.':{
                flag=true;
                break;
            }
            default:{
                res=res*10+s[i]-'0';
                if(flag){
                    times*=10;
                }
            }
        }
        i++;        
    }
}

int main()
{
    int ca,cnt=0;
    scanf("%d",&ca);
    getchar();
    while(ca--)
    {
        cnt++;
        getline(cin,s);
        int a,b,c;
        a=s.find("U=");
        b=s.find("I=");
        c=s.find("P=");
        printf("Problem #%d\n",cnt);
        if(a<0){
            printf("U=%.2fV\n",fval(c)/fval(b));
        }else if(b<0){
            printf("I=%.2fA\n",fval(c)/fval(a));
        }else{
            printf("P=%.2fW\n",fval(a)*fval(b));
        }
        printf("\n");
    }
    return 0;
}

我队友的代码:

你可能感兴趣的:(poj)