Bone Collector

Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … 
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? 

 

Input

The first line contain a integer T , the number of cases. 
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output

One integer per line representing the maximum of the total value (this number will be less than 2  31).
 

Sample Input

        
        
        
        
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output

        
        
        
        
14
 

纯粹的01背包问题!

#include<stdio.h>
#include<string.h>
#define M 1009
struct pack
{
	int cost;
	int val;
}a[M];
int main()
{
	int cas,n,v,i,j;
	int dp[M];
	scanf("%d",&cas);
	while(cas--)
	{
		scanf("%d%d",&n,&v);
		memset(dp,0,sizeof(dp));
		for(i=1;i<=n;i++)
			scanf("%d",&a[i].val);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i].cost);
		for(i=1;i<=n;i++)
			for(j=v;j>=a[i].cost;j--)//注意次序,跟完全背包相反
				if(dp[j]<dp[j-a[i].cost]+a[i].val) 
					dp[j]=dp[j-a[i].cost]+a[i].val;
		printf("%d\n",dp[v]);
	}
	return 0;
}




你可能感兴趣的:(Bone Collector)