ZOJ 3882 Help Bob

There is a game very popular in ZJU at present, Bob didn't meant to participate in it. But he decided to join it after discovering a lot of pretty girls playing it.

There are n stones on the ground and they are marked as 1 to n respectively. There will be 2 players in each competition. And the game rules are simple, A and B take turns to move. Each round, one of them can only take 1 number away, and then pick out all the divisors of the choosed number. When anyone who can not take away 1 number any longer, he will fail the whole game.

Input

There are multiple cases. Each case include an integer number n (0 ≤ n ≤ 100).

Output

For each case, A win, output "win". If not, output"fail".

Sample Input1

3
4

Sample Output1

win

win

假设有先手必败,那么此时取1,得到的剩下的情况仍旧会是先手必败,矛盾

所以先手必胜,注意特判0

#include<cstdio>
#include<cmath>
#include<queue>
#include<vector>
#include<stack>
#include<map>
#include<string>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
typedef long long ll;
const ll maxn = 100005;
int T, n, m, f[maxn], dp[maxn * 10];

int main()
{
	while (scanf("%d", &n) == 1)
	{
		if (n == 0) printf("fail\n");
		else printf("win\n");
	}
	return 0;
}


你可能感兴趣的:(ZOJ)