HDOJ【C】1.1.5 A+B for Input-Output Practice (V)

A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7895 Accepted Submission(s): 5854

Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output
For each group of input integers you should output their sum in one line, and with one line of output for each line in input. 
 

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5
 

Sample Output
10
15
 

Author
lcy
 



#include <stdio.h>  
  
void main()
{   
    int n,i,m,sum,j,a;  
    scanf("%d",&m); 
    scanf("%d",&n);   
	for(j=0;j<m;j++)
	{
       
	     sum=0;
         for(i=0; i<n; i++)
		 {   
             scanf("%d",&a); 
		   	 sum=sum+a;
         }   
         printf("%d\n", sum);   
         if(j==m-1)
		   break;
	    scanf("%d",&n); 
	}   
}  




你可能感兴趣的:(HDOJ【C】1.1.5 A+B for Input-Output Practice (V))