HDOJ 【C】1.1.8 A+B for Input-Output Practice (VIII)

A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17969 Accepted Submission(s): 5674

Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3
 

Sample Output
10

15

6
 



Author
lcy
 


Recommend
JGShining


#include<stdio.h>
void main()
{
  int i,n,a,sum,m,j;
   scanf("%d",&m);
   for(j=0;j<m;j++)
   {
     scanf("%d",&n);
     sum=0;
     for(i=0;i<n;i++)
	 {
      scanf("%d",&a);
       sum+=a;
	 }
      printf("%d",sum);
     if(j!=m-1)
	 {
      printf("\n\n");
	 }
     else
     printf("\n");
   }
}
最后一行输出是不用空一行的


你可能感兴趣的:(HDOJ 【C】1.1.8 A+B for Input-Output Practice (VIII))