HDOJ 2122 Ice_cream’s world III(最小生成树--prime 水)

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1245    Accepted Submission(s): 410


Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 

Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 

Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 

Sample Input
   
   
   
   
2 1 0 1 10 4 0
 

Sample Output
   
   
   
   
10 impossible ac代码:
#include<stdio.h>
#include<string.h>
#include<iostream>
#include<algorithm>
#define MAXN 10100
#define INF 0xfffffff
#define max(a,b) a>b?a:b
#define min(a,b) a>b?b:a
using namespace std;
int pri[MAXN][MAXN];
int dis[MAXN];
int v[MAXN];
int n,bz,sum;
void prime()
{
	int i,k,j;
	int M; 
	memset(v,0,sizeof(v));
	for(i=0;i<n;i++)
	dis[i]=pri[0][i];
	v[0]=1;
	sum=0;
	for(i=1;i<n;i++)
	{
		M=INF;
		k=-1;
		for(j=0;j<n;j++)
		{
			if(v[j]==0&&dis[j]<M)
			{
				M=dis[j];
				k=j;
			}
		}
		if(M==INF)
		break;
		sum+=M;
		v[k]=1;
		for(j=0;j<n;j++)
		{
			if(v[j]==0)
			dis[j]=min(dis[j],pri[k][j]);
		}
	}
	if(k==-1)
	sum=-1;
}
int main()
{
	int i,j,a,b,c,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		for(i=0;i<n;i++)
		{
			for(j=0;j<n;j++)
			{
				pri[i][j]=INF;
			}
		}
		for(i=0;i<m;i++)
		{
			scanf("%d%d%d",&a,&b,&c);
			if(pri[a][b]>c)
			pri[a][b]=pri[b][a]=c;
	    }
	    prime();
	    if(sum==-1)
	    printf("impossible\n");
	    else
	    printf("%d\n",sum);
	    printf("\n");
	}
	return 0;
}


你可能感兴趣的:(HDOJ 2122 Ice_cream’s world III(最小生成树--prime 水))