HDU 1241 Oil Deposits DFS

HDU 1241 Oil Deposits

Problem Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. 

Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 


Sample Output

0
1
2
2

这道题意思是说,有一片土地,用*表示空地,用@表示油田,求多少油田(上下相连和左右相连,以及对角线的算一块油田)。也就是说只要八个方向相连,就算一块油田。用深搜,八个方向遍历一遍就行了。
代码如下:


 #include<iostream>
 #include <cstdio>
 #include <string.h>
 #define N 105
using namespace std;

char a[N][N];
int dir[8][2]={{-1, 0}, {1, 0}, {0, 1}, {0, -1}, {-1, 1}, {-1, -1}, {1, 1}, {1, -1}};
int n, m;

void dfs(int x, int y)
{
    int nx, ny;
    for (int i = 0; i < 8; i++)//依次扫描八个方向,寻找可行点
    {
        nx = x + dir[i][0];
        ny = y + dir[i][1];
        if (nx >= 0 && nx < m && ny >= 0 && ny < n &&a[nx][ny] == '@' )//判断是否超出地图边界和是否可行
        {
            a[nx][ny] = '!'; //标记已经走过的点 
            dfs(nx, ny);
        }
    }
}

int main()
{
    int  count;
 #ifndef ONLINE_JUDGE
    freopen("1.txt", "r", stdin);
 #endif 
    int  i, j;
    while (scanf("%d%d", &m, &n), m)
    {
        memset(a, 0, sizeof(a));
        for(i = 0; i < m; i++)
        {
            scanf("%s", a[i]);
        }
        count = 0;
        for (i = 0; i < m; i++) //分别以每个点为起点扫描一次,判断连通分量个数即可 
        {
            for (j = 0; j < n; j++)
            {
                if (a[i][j] == '@')   //忽略掉没有油田的点 
                {
                    a[i][j] = '!';   //标记该点已经走过 
                    dfs(i, j);
                    count++;
                }
            }
        }
        cout << count << endl;
    }
    return 0;
} 

你可能感兴趣的:(DFS,杭电)